DMSF and Redmine 2.x

Added by Buzze Kr ies almost 8 years ago

Hi there folks,

setting up Redmine 2.0, I came across following thing.
DMSF Plugin does not install anymore.
Depending on the changed "Plugin" directory, I'm
kind of a Blockhead.
Does anybody experience the same problem?
Does any one has a clue for me?

Is there an alternative maybe for DMSF?

I am setting the Redmine up in Ubuntu 12 with Passenger and MySQL.

Thanks in advance.

BR
A.

Replies (9)

RE: DMSF and Redmine 2.x - Added by Daniel Munn almost 8 years ago

Have a look here: https://github.com/danmunn/redmine_dmsf

Although a work that is in-progress I've got a branch of dmsf that supports redmine 2.x.

RE: DMSF and Redmine 2.x - Added by Buzze Kr ies almost 8 years ago

Good to hear, Dan.
Thanks for your response.

I updated to Redmine 2.0.2.

Sorry, if I bother, but I have following problem:
Running the "rake redmine:plugins:migrate RAILS_ENV="production" command, I get
"You passed :optional as an option for gem 'xapian-full', but it is invalid."

I installed Xapian etc. Packages as mentioned on the page named above.

Any Idea?
Help really appreciated.

BR

A.

RE: DMSF and Redmine 2.x - Added by Daniel Munn almost 8 years ago

Just updated, for some reason I'd read proposed functionality for bundler and included it as if it was in mainstream branch (which it isnt) if you update again should work without issue.

If you do not use the xapian gem, its recommended to run:
bundle --without=xapian

from within the plugin directory.

RE: DMSF and Redmine 2.x - Added by Buzze Kr ies almost 8 years ago

Hi there Dan,

good work. Thanks for your quick response.
May I ask another question?
On the git hub page mentioned above, I do download the ZIP file.
Is that right? Just to be sure, that I do not fail in such a simple step. :))

May I ask another question?
Since I am new to Ruby/Rails/Rake stuff, bundle install of Xapian-full 1.2.3 does not succeed and I have no clue.
I assume, that it is not really related to the DMSF issue,but may I ask:
When running bundle install in the redmine_dmsf directory, install breaks with:
"Installing xapian-full (1.2.3) with native extensions
Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.
"
I included Gemmakeout File in attachment.

Can you help again?
Again, many thanks in advance.

BR
A.

gem_make.out (84.2 KB)

RE: DMSF and Redmine 2.x - Added by Daniel Munn almost 8 years ago

from SSH (assuming you've got access to this) - and assuming you're in the redmine root folder:

cd plugins/redmine_dmsf
bundle --without=xapian

Then try re-starting the rails application.

Also, if you grab the source via git, as opposed to downloading it as a zip, again assuming you've ssh to this server, you can run "git pull" to get latest code updates without having to worry about extracting zip files, uploading etc...

RE: DMSF and Redmine 2.x - Added by Buzze Kr ies almost 8 years ago

Hi there Dan,

first of all, I want to thank you very much for your support.

I still experience the xapian error as described above.
Wether I want to install w/o or with xapian.
"ERROR: Error installing xapian-full:
ERROR: Failed to build gem native extension."
"configure: error: in `/var/lib/gems/1.9.1/gems/xapian-full-1.2.3/xapian-core-1.2.3':
configure: error: C compiler cannot create executables"
I also installed ubuntu 12 server and redmine from scratch with the same result.

Since I have a fall-back solution for the DMSF issue, I can understand if this xapian thing bothers you and you do not want to invest more time in it.
But, again, help is appreciated.

BR

A.

RE: DMSF and Redmine 2.x - Added by Daniel Munn almost 8 years ago

Okay try the following:

On the redmine root, run:

bundle --without test development xapian

and after that try running redmine and see if you're still having issues.

Best Regards,

RE: DMSF and Redmine 2.x - Added by Buzze Kr ies almost 8 years ago

Hi Dan,

finally made it. :)

With your help and a Patch a found for the Xapian Gem
(look here: http://atomicules.co.uk/2011/12/26/A-Quick-Note-for-Idiots-%28me%29-on-Installing-the-xapian-full-gem-on-Linux.html),
i managed to install Xapian Indexing ability as well.

Many, many thanks for you help.

BR
A.

RE: DMSF and Redmine 2.x - Added by Henry Li 3 months ago

Buzze Kr ies wrote:

Hi Dan,

finally made it. :)

With your help and a Patch a found for the Xapian Gem
(look here: http://atomicules.co.uk/2011/12/26/A-Quick-Note-for-Idiots-%28me%29-on-Installing-the-xapian-full-gem-on-Linux.html),
i managed to install Xapian Indexing ability as well.

Many, many thanks for you help.

BR
A.

thanks, just try to install dmsf plugin without xapian by revising dockefile:
bundle --without test development xapian

(1-9/9)