Installing plugin: Could not find gem 'factory_girl_rails (>= 0) ruby' in the gems available on this machine.

Added by Vadim Epstein about 7 years ago

Installing plugin "Redmine_reminder" (http://www.redmine.org/plugins/redmine_reminder).
Environment:
Redmine version 2.3.1.stable.11966
Ruby version 1.8.7 (x86_64-linux)
Rails version 3.2.13
Environment production
Database adapter Mysql2

When run:
bundle exec rake redmine:plugins:migrate RAILS_ENV=production
or
rake redmine:plugins:migrate RAILS_ENV=production

I get error: "Could not find gem 'factory_girl_rails (>= 0) ruby' in the gems available on this machine".

Could you please advise how to solve it?

Replies (3)

RE: Installing plugin: Could not find gem 'factory_girl_rails (>= 0) ruby' in the gems available on this machine. - Added by Georg Bretschneider about 7 years ago

Bundle install isn't doing the trick.
Not even "gem install factory_girl_rails", because the current version (4.x) isn't supported for ruby 1.8.7, but ruby 1.9.
According to the developers one have to install version 1.7.0 (gem install factory_girl_rails -v 1.7.0) but this breaks with:

ERROR: Error installing factory_girl_rails:
activesupport requires Ruby version >= 1.9.3.

Ruby 1.8.7 is the supported version for Redmine 2.3, maybe you can somehow solve these dependencies and put the exact to be installed version in the plugins Gemfile.

(1-3/3)