can't install periodictask plugin

Added by marcelo martinez almost 6 years ago

Hello,

I'm trying to install periodictask plugin: https://github.com/jperelli/Redmine-Periodic-Task/

git clone -b redmine2 http://github.com:/jperelli/Redmine-Periodic-Task.git plugins/periodictask
Cloning into 'plugins/periodictask'...
remote: Counting objects: 410, done.
remote: Total 410 (delta 0), reused 0 (delta 0), pack-reused 410
Receiving objects: 100% (410/410), 57.65 KiB | 0 bytes/s, done.
Resolving deltas: 100% (163/163), done.

/home/support/download/redmine/redmine-3.2.0/bin/rake redmine:plugins:migrate NAME=periodictask RAILS_ENV=production
Please configure your config/database.yml first
(in /var/www/redmine)
rake aborted!
Gem::LoadError: Specified 'mysql2' for database adapter, but the gem is not loaded. Add `gem 'mysql2'` to your Gemfile (and ensure its version is at the minimum required by ActiveRecord).
/usr/local/share/gems/gems/activerecord-4.2.5/lib/active_record/connection_adapters/connection_specification.rb:177:in `rescue in spec'
/usr/local/share/gems/gems/activerecord-4.2.5/lib/active_record/connection_adapters/connection_specification.rb:174:in `spec'
/usr/local/share/gems/gems/activerecord-4.2.5/lib/active_record/connection_handling.rb:50:in `establish_connection'
/usr/local/share/gems/gems/activerecord-4.2.5/lib/active_record/railtie.rb:120:in `block (2 levels) in <class:Railtie>'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/lazy_load_hooks.rb:38:in `instance_eval'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/lazy_load_hooks.rb:38:in `execute_hook'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/lazy_load_hooks.rb:45:in `block in run_load_hooks'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/lazy_load_hooks.rb:44:in `each'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/lazy_load_hooks.rb:44:in `run_load_hooks'
/usr/local/share/gems/gems/activerecord-4.2.5/lib/active_record/base.rb:315:in `<module:ActiveRecord>'
/usr/local/share/gems/gems/activerecord-4.2.5/lib/active_record/base.rb:26:in `<top (required)>'
/var/www/redmine/lib/plugins/acts_as_activity_provider/init.rb:2:in `block in <top (required)>'
/var/www/redmine/config/initializers/00-core_plugins.rb:12:in `eval'
/var/www/redmine/config/initializers/00-core_plugins.rb:12:in `block in <top (required)>'
/var/www/redmine/config/initializers/00-core_plugins.rb:2:in `each'
/var/www/redmine/config/initializers/00-core_plugins.rb:2:in `<top (required)>'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:268:in `load'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:268:in `block in load'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:268:in `load'
/usr/local/share/gems/gems/railties-4.2.5/lib/rails/engine.rb:652:in `block in load_config_initializer'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/notifications.rb:166:in `instrument'
/usr/local/share/gems/gems/railties-4.2.5/lib/rails/engine.rb:651:in `load_config_initializer'
/usr/local/share/gems/gems/railties-4.2.5/lib/rails/engine.rb:616:in `block (2 levels) in <class:Engine>'
/usr/local/share/gems/gems/railties-4.2.5/lib/rails/engine.rb:615:in `each'
/usr/local/share/gems/gems/railties-4.2.5/lib/rails/engine.rb:615:in `block in <class:Engine>'
/usr/local/share/gems/gems/railties-4.2.5/lib/rails/initializable.rb:30:in `instance_exec'
/usr/local/share/gems/gems/railties-4.2.5/lib/rails/initializable.rb:30:in `run'
/usr/local/share/gems/gems/railties-4.2.5/lib/rails/initializable.rb:55:in `block in run_initializers'
/usr/local/share/gems/gems/railties-4.2.5/lib/rails/initializable.rb:44:in `each'
/usr/local/share/gems/gems/railties-4.2.5/lib/rails/initializable.rb:44:in `tsort_each_child'
/usr/local/share/gems/gems/railties-4.2.5/lib/rails/initializable.rb:54:in `run_initializers'
/usr/local/share/gems/gems/railties-4.2.5/lib/rails/application.rb:352:in `initialize!'
/var/www/redmine/config/environment.rb:14:in `<top (required)>'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:274:in `require'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:274:in `block in require'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:274:in `require'
/var/www/redmine/plugins/periodictask/lib/tasks/periodictask.rake:7:in `<top (required)>'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:268:in `load'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:268:in `block in load'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:268:in `load'
/var/www/redmine/lib/tasks/redmine.rake:186:in `block in <top (required)>'
/var/www/redmine/lib/tasks/redmine.rake:186:in `each'
/var/www/redmine/lib/tasks/redmine.rake:186:in `<top (required)>'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:268:in `load'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:268:in `block in load'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/local/share/gems/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:268:in `load'
/usr/local/share/gems/gems/railties-4.2.5/lib/rails/engine.rb:658:in `block in run_tasks_blocks'
/usr/local/share/gems/gems/railties-4.2.5/lib/rails/engine.rb:658:in `each'
/usr/local/share/gems/gems/railties-4.2.5/lib/rails/engine.rb:658:in `run_tasks_blocks'
/usr/local/share/gems/gems/railties-4.2.5/lib/rails/application.rb:452:in `run_tasks_blocks'
/usr/local/share/gems/gems/railties-4.2.5/lib/rails/engine.rb:453:in `load_tasks'
/usr/local/share/gems/gems/railties-4.2.5/lib/rails/railtie.rb:194:in `public_send'
/usr/local/share/gems/gems/railties-4.2.5/lib/rails/railtie.rb:194:in `method_missing'
/var/www/redmine/Rakefile:7:in `<top (required)>'
(See full trace by running task with --trace)

The database.yml is already configured for production, we're using mysql.

Redmine version is 3.2.0

Any help please?

Thanks in advance!

Marcelo.-

Replies (1)

RE: can't install periodictask plugin - Added by Julian Perelli almost 6 years ago

If you are using redmine 3.2.0, please git clone directly from master. i.e: do not use option "-b redmine2". Tell me if that fixes your problem.

Disclaimer: I'm the mantainer of the plugin

(1-1/1)