Project

General

Profile

Actions

Defect #10071

closed

Redmine Administrator is limited by roles, memberships and workflows

Added by Adam Piotr ┼╗ochowski about 12 years ago. Updated about 12 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Issues workflow
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate
Affected version:

Description

Scenario:

User leaves company. All their issues that are open and ones that were closed in last 2 weeks need to be reassigned with a custom status. As administrator I try to change status and I am told I don't have permissions. Now I have to add myself to project, only to change status, and then remove myself from project. And I have to do that many times from many different projects.

Solutions:

For Redmine administrators allow all actions, give warning if they do something that is outside of typical use (like changing status outside of typical workflow).

Kind regards
Adam Zochowski


Related issues

Is duplicate of Redmine - Feature #2323: Workflow permissions for administratorsClosedJean-Philippe Lang2008-12-12

Actions
Actions #1

Updated by Alex Shulgin about 12 years ago

This bugs me as well.

Not sure about workflows, but it is very reasonable that admin users should be able to act on projects regardless of the membership.

Actions #2

Updated by Jean-Philippe Lang about 12 years ago

  • Category set to Issues workflow
  • Status changed from New to Closed
  • Resolution set to Duplicate

Same as #2323, which has just been fixed.

Actions

Also available in: Atom PDF