Project

General

Profile

Actions

Defect #10474

closed

Gems version conflict in Redmine core and plugins

Added by John Yani about 12 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Plugin API
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Wont fix
Affected version:

Description

Currently Redmine's Gemfile includes plugin Gemfiles.

This could be a problem if plugin's Gemfile contains a different version of gem.

See an example of a potential problem: https://github.com/backlogs/redmine_backlogs/issues/465

If Gemfile contain two gems, you'll get an error:

You cannot specify the same gem twice with different version requirements.

Actions #1

Updated by Harry Garrood about 11 years ago

This is by design. Redmine's Gemfile includes plugin Gemfiles because it's much better to ensure that there are no unsatisfiable requirements at load time, than to not check and hope it will work. (The latter leads to hours wasted trying to debug the problems which arise)

You cannot specify the same gem twice with different version requirements.

If this happens to you, you need to edit the plugin's Gemfile to relax the version constraint. Note that you don't need to have a version requirement; you can put just gem 'foo' to tell Bundler that you don't care what version you're using.

This issue should probably be closed.

Actions #2

Updated by Toshi MARUYAMA about 11 years ago

  • Category set to Plugin API
Actions #3

Updated by Toshi MARUYAMA about 11 years ago

  • Subject changed from Gemfile and plugins to Gems version in Gemfile conflict in Redmine core and plugins
Actions #4

Updated by Toshi MARUYAMA about 11 years ago

  • Subject changed from Gems version in Gemfile conflict in Redmine core and plugins to Gems version conflict in Redmine core and plugins
Actions #5

Updated by Go MAEDA about 1 year ago

  • Status changed from New to Closed
  • Resolution set to Wont fix

In a Ruby on Rails application, it is impossible to use two different versions of the same gem simultaneously.

Actions

Also available in: Atom PDF