Defect #11337

No mail notifications sent after upgrade

Added by Krisztian Kocsis about 8 years ago. Updated almost 8 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Email notifications
Target version:-
Resolution:Invalid Affected version:2.0.3

Description

After I'v upgraded Redmine from 1.4.3 to 2.0.3 it stopped sending mail notifications.
The configuration file seems OK (didn't change) but I didn't see anything from the associated email mailbox in /var/log/mail.log.
Also there are no more 'Sending email notification to: ...' lines in Redmine's log.

About your application's environment
Ruby version 1.8.7 (x86_64-linux)
RubyGems version 1.7.2
Rack version 1.4
Rails version 3.2.6
Active Record version 3.2.6
Action Pack version 3.2.6
Active Resource version 3.2.6
Action Mailer version 3.2.6
Active Support version 3.2.6
Middleware Rack::Cache, ActionDispatch::Static, Rack::Lock, #<ActiveSupport::Cache::Strategy::LocalCache::Middleware:0x7f28c791a630>, Rack::Runtime, Rack::MethodOverride, ActionDispatch::RequestId, Rails::Rack::Logger, ActionDispatch::ShowExceptions, ActionDispatch::DebugExceptions, ActionDispatch::RemoteIp, ActionDispatch::Callbacks, ActiveRecord::ConnectionAdapters::ConnectionManagement, ActiveRecord::QueryCache, ActionDispatch::Cookies, ActionDispatch::Session::CookieStore, ActionDispatch::Flash, ActionDispatch::ParamsParser, ActionDispatch::Head, Rack::ConditionalGet, Rack::ETag, ActionDispatch::BestStandardsSupport, OpenIdAuthentication
Application root /opt/redmine/optimaster
Environment production
Database adapter sqlite3
Database schema version 20120422150750

What other information do you need to fix this bug?

configuration.yml Magnifier (5.63 KB) Krisztian Kocsis, 2012-07-16 07:47

History

#1 Updated by Etienne Massip about 8 years ago

What's your email configuration looks like?

#2 Updated by Etienne Massip about 8 years ago

  • Priority changed from High to Normal

#3 Updated by Krisztian Kocsis about 8 years ago

I'v attached my config file.

#4 Updated by Etienne Massip about 8 years ago

Do you have lines in your production.log telling that the application is parsing mailer views (a.k.a. mailer/*anything*)?

#5 Updated by Krisztian Kocsis about 8 years ago

Yes, I have the following lines:

Rendered mailer/_issue.text.erb (3.3ms)
Rendered mailer/issue_edit.text.erb within layouts/mailer (5.3ms)
Rendered mailer/_issue.html.erb (1.2ms)
Rendered mailer/issue_edit.html.erb within layouts/mailer (2.7ms)

#6 Updated by Etienne Massip about 8 years ago

Does it work when you change all async_smtp_ to smtp_ (i.e., use synchronous notifications) in your configuration?

#7 Updated by Krisztian Kocsis about 8 years ago

Previously it was smtp_.
Tried, did not help.

#8 Updated by Etienne Massip about 8 years ago

Does test mail work?

#9 Updated by Krisztian Kocsis about 8 years ago

Okay, it is not a bug, it is a misconfiguration.
Some default ActionMailer config may changed.

I had to set enable_starttls_auto to false since there was a hostname does not match CN problem.

#10 Updated by Etienne Massip about 8 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

Krisztian Kocsis wrote:

I had to set enable_starttls_auto to false since there was a hostname does not match CN problem.

Where could you see this error message please?

#11 Updated by Krisztian Kocsis about 8 years ago

On Settings -> Email notifications page after I tried to send the test email.

#12 Updated by Krisztian Kocsis about 8 years ago

There was something else instead of CN!

#13 Updated by Fernando Hartmann almost 8 years ago

Krisztian Kocsis wrote:

There was something else instead of CN!

It happened in my 2.0.4 install too, and the error is

An error occurred while sending mail (hostname was not match with the server certificate)

Yes, my email server has configuration problems, but worked well with Redmine 1.4.4. I needed include enable_starttls_auto: false in configuration to work again.
My configuration.yml now is likely

production:
  email_delivery:
    delivery_method: :smtp
    smtp_settings:
      address: mail.server
      port: 25
      tls: false
      enable_starttls_auto: false
      domain: server.domain
      authentication: :none

Also available in: Atom PDF