Defect #12536

Missing 'parent' field for projects REST API

Added by Matthias Lamoureux over 9 years ago. Updated over 9 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:REST API
Target version:-
Resolution:Cant reproduce Affected version:2.1.4

Description

When using the projects API for a given project, for example projects/189.xml, the parent field is not returned whereas it is when using the full list of projects projects.xml.

History

#1 Updated by Matthias Lamoureux over 9 years ago

Title should be : Missing 'parent' field for projects REST API

#2 Updated by Toshi MARUYAMA over 9 years ago

  • Subject changed from Adding 'parent' field for projects REST API to Missing 'parent' field for projects REST API

#3 Updated by Jean-Philippe Lang over 9 years ago

  • Status changed from New to Closed
  • Resolution set to Cant reproduce

The parent is present in the API response for a single project: source:/tags/2.1.4/app/views/projects/show.api.rsb (unless the project is a root project).

Also available in: Atom PDF