Project

General

Profile

Actions

Defect #14041

closed

Email notification error: incompatible character encodings: UTF-8 and ASCII-8BIT

Added by Alexandr Sobolev almost 11 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Email notifications
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Cant reproduce
Affected version:

Description

Hello!
I'm configured notification via mail.ru.
My config file:

production:
   email_delivery:
     delivery_method: :smtp
     smtp_settings:
       address: smtp.mail.ru
       domain: mail.ru
       port: 25
       authentication: :login
       user_name: 'test@mail.ru'
       password: 'blabla'

When i send test mail, get error:

Encoding::CompatibilityError (incompatible character encodings: UTF-8 and ASCII-8BIT):
  lib/redmine/i18n.rb:32:in `l'
  app/controllers/admin_controller.rb:68:in `rescue in test_email'
  app/controllers/admin_controller.rb:64:in `test_email'

Environment:
  Redmine version                          2.3.0.stable
  Ruby version                             1.9.3 (x86_64-linux)
  Rails version                            3.2.13
  Environment                              production
  Database adapter                         Mysql2

my session and global variables MySQL:

character set client            utf8
character set connection    utf8    
character set database            utf8    
character set filesystem    binary    
character set results            utf8    
character set server            utf8    
character set system            utf8
character sets dir            /usr/share/mysql/charsets/

Help please!
Thanks!

Actions #1

Updated by Toshi MARUYAMA almost 11 years ago

  • Subject changed from Email notification error to Email notification error: incompatible character encodings: UTF-8 and ASCII-8BIT
Actions #2

Updated by Toshi MARUYAMA almost 11 years ago

Actions #3

Updated by Toshi MARUYAMA almost 11 years ago

  • Status changed from New to Needs feedback
Actions #4

Updated by Alexandr Sobolev almost 11 years ago

  • yes
  • yes
  • my db was UTF-8
Actions #5

Updated by Toshi MARUYAMA almost 11 years ago

  • Status changed from Needs feedback to New
Actions #6

Updated by Toshi MARUYAMA almost 11 years ago

Sending test mail tests pass in all locales.
source:tags/2.3.1/test/unit/mailer_test.rb#L495

Actions #7

Updated by Go MAEDA about 1 month ago

  • Status changed from New to Closed
  • Resolution set to Cant reproduce
Actions

Also available in: Atom PDF