Defect #14995

Japanese "notice_not_authorized" translation is incorrect

Added by Akihiro MATOBA about 4 years ago. Updated about 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Translations
Target version:2.4.0
Resolution:Fixed Affected version:2.3.3

Description

source:trunk/config/locales/ja.yml#L191

incorrect:
notice_not_authorized: このページにアクセスするには認証が必要です。

correct:
notice_not_authorized: このページにアクセスするには認可が必要です。

reproduce procedure:
Log in an account not have administrator role, then try to open /admin.

Associated revisions

Revision 12177
Added by Toshi MARUYAMA about 4 years ago

Japanese "notice_not_authorized" translation changed (#14995)

History

#1 Updated by Jan Niggemann (redmine.org team member) about 4 years ago

  • Assignee set to Toshi MARUYAMA

#2 Updated by Toshi MARUYAMA about 4 years ago

  • Assignee deleted (Toshi MARUYAMA)

#3 Updated by Toshi MARUYAMA about 4 years ago

  • Subject changed from Japanese: incorrect message to notice_not_authorized is incorrect
  • Category changed from Translations to UI
  • Affected version (unused) set to 2.3.3
  • Affected version set to 2.3.3

#4 Updated by Toshi MARUYAMA about 4 years ago

English:

notice_not_authorized: You are not authorized to access this page.

Should it be "You do not have permissions to access this page."?

#5 Updated by Mischa The Evil about 4 years ago

Toshi MARUYAMA wrote:

English:

notice_not_authorized: You are not authorized to access this page.

Should it be "You do not have permissions to access this page."?

Well, I think the current English translation is correct because authorization is (very briefly and highly generalized) the process of specifying and controlling access rights based on predefined permissions (read: you are not authorized... == you do not have permissions...).

Why do you think such a change is (possibly) needed? Or is it that you wanted to check the meaning of this English translation to make sure whether or not the Japanese translation needs to be changed as proposed by Akihiro MATOBA?

#6 Updated by Toshi MARUYAMA about 4 years ago

  • Subject changed from notice_not_authorized is incorrect to Japanese "notice_not_authorized" translation is incorrect
  • Category changed from UI to Translations
  • Target version set to 2.4.0

#7 Updated by Toshi MARUYAMA about 4 years ago

  • Status changed from New to Closed
  • Resolution set to Fixed

Mischa The Evil wrote:

Toshi MARUYAMA wrote:

English:

notice_not_authorized: You are not authorized to access this page.

Should it be "You do not have permissions to access this page."?

Well, I think the current English translation is correct because authorization is (very briefly and highly generalized) the process of specifying and controlling access rights based on predefined permissions (read: you are not authorized... == you do not have permissions...).

Why do you think such a change is (possibly) needed? Or is it that you wanted to check the meaning of this English translation to make sure whether or not the Japanese translation needs to be changed as proposed by Akihiro MATOBA?

Thank you.
I have translated Japanese r12177 simply from English.

Also available in: Atom PDF