Defect #15793

Problems with recieving emails with attached .msg files

Added by Evgeniy Cn almost 9 years ago. Updated 5 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Evgeniy Cn% Done:

0%

Category:Email receiving
Target version:-
Resolution:Cant reproduce Affected version:2.3.1

Description

If user send email via Outlook with attached .msg file (MS Outlook mail) Redmine will ignore it and add to the issue just text from message-body.
There is the same issue in this topic: #8093
But no respond for one year, any ideas how to fix it ?

Thank you.

Test issue.msg (38 KB) Evgeniy Cn, 2014-01-06 11:39

issue.JPG (17.7 KB) Evgeniy Cn, 2014-01-06 11:40


Related issues

Related to Redmine - Defect #8093: Incoming email with internal emails as attachments isn't ... New 2011-04-07

History

#1 Updated by Daniel Felix almost 9 years ago

  • Related to Defect #8093: Incoming email with internal emails as attachments isn't processed properly added

#2 Updated by Jean-Philippe Lang almost 9 years ago

Could you post the content of an email fo which you have this problem?

#3 Updated by Evgeniy Cn almost 9 years ago

It doesn't metter what kind of content mails has, if it has attached .msg file, this file will not be upload, wihout any error in the logs, just like there is no any attached .msg file at all.

#4 Updated by Jean-Philippe Lang almost 9 years ago

  • Status changed from New to Needs feedback
  • Assignee set to Evgeniy Cn

I don't have Outlook and can't test this without a sample email, can you post one? I've made a test with the one provided in #8093 and it works fine.

#5 Updated by Toshi MARUYAMA almost 9 years ago

  • Description updated (diff)

#6 Updated by Evgeniy Cn almost 9 years ago

I attached "test issue".msg with other .msg file inside and issue.jpg (that how it looks in redmine, no any attachments).

#7 Updated by Jean-Philippe Lang almost 9 years ago

  • Resolution set to Cant reproduce

I had to convert you msg to eml so I can load it with rake redmine:email:read. After that, the issue is properly created with a "Test.eml" attachment.

#8 Updated by Toshi MARUYAMA almost 9 years ago

  • Status changed from Needs feedback to Closed

#9 Updated by Jan Catrysse 5 months ago

This still is an issue.

When outlook adds mail messages as an attachment, it uses this type of headers:

...
--_012_342b0886c5894875a2dadf9b72a8b986XXXXXXXXXXXXXXXXX_
Content-Type: message/rfc822
Content-Disposition: attachment;
    creation-date="Tue, 21 Jun 2022 16:05:12 GMT";
    modification-date="Tue, 21 Jun 2022 16:05:12 GMT" 

Received: from XXXX.XXXXX.LOCAL (192.168.254.15) by
...

and not regular attachments... those parts are not handled correctly.

One should expect the message is attached as an attachment to the issue, and now the system is extracting the attachments from the attached message, but not the message itself.

I suspect this is an issue with the mail gem...

#10 Updated by Jan Catrysse 5 months ago

I added a very dirty fix in #8093.

But it would be nice to have this addressed by someone more proficient.

Also available in: Atom PDF