Project

General

Profile

Actions

Defect #16161

closed

Parent task search and datepicker not available after changing status

Added by Daniele Pedroni about 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Category:
Issues
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Fixed
Affected version:

Description

I played a bit with read only field for trackers and users throughout all my Redmine setup, but now I found out a problem.
When I try to create a new issue, only Tracker, Status and Parent Task fields are visible, and Parent Task has its Magnifier lens image in it, so if I type something it the field, it starts the contextual search.

Right view, as expected

But then, when I change the status and the page is redrawn as per specific tracker/issue, Parent Task loses its Magnifier and the capability of search with it; same thing for due date and start date datepicker, not available at all.

Wrong view

Finally, if I create the issue and then try to update it, both Parent Task search and datepicker are back as usual.

Any idea?

My Redmine installation comes from Bitnami stack 2.4.2-0, containing:
- Redmine 2.4.2
- Apache 2.4.7
- ImageMagick 6.7.5
- MySQL 5.5.34
- Subversion 1.8.4
- Git 1.8.3
- Ruby 1.9.3-p484
- Rails 3.2.16
- RubyGems 1.8.12

and plugins:
- extended fields 0.2.2
- projects table plugin 0.0.4
- DMSF 1.4.7 stable
- Redmine Multi Column Custom Fields plugin 0.0.1
- Redmine Tracker Control plugin 1.0.8


Files

NewIssueKO.png (7.15 KB) NewIssueKO.png Wrong view Daniele Pedroni, 2014-02-24 12:59
NewIssueOK.png (5.11 KB) NewIssueOK.png Right view, as expected Daniele Pedroni, 2014-02-24 12:59

Related issues

Related to Redmine - Defect #16270: Patch not working as expected from #16161 in r12491Closed

Actions
Actions #1

Updated by Jean-Philippe Lang about 10 years ago

  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang
  • Target version set to 2.4.4
  • Resolution set to Fixed

This was due to the fact that the description field was read-only when the page is loaded.
It's fixed in r12941, thanks for poiting this out.

Actions #2

Updated by Daniele Pedroni about 10 years ago

  • Status changed from Closed to Reopened

Sorry JPL,

following your explanation I tried disabling read only attribute for Description field, in order to get the scripts back without having to wait for 2.4.4 release, but with no luck: I see also Description before changing status, but the datepicker and contextual search for Parent task are still missing. Even with all global fields without read only property (I left other custom fields as read only, but I don't think it could be related), the problem is present.

I didn't restart Redmine process after workflow modification, but I don't understand why this should be necessary... Are you sure your patch will work in any condtion?

Thank you for your great support.

Actions #3

Updated by Jean-Philippe Lang about 10 years ago

  • Status changed from Reopened to Needs feedback

Well, I was able to reproduce with the configuration as in your first screenshot and r12941 fixed it. Tested with Chrome and Firefox.

Maybe a plugin issue, please try this out without any plugin.

Actions #4

Updated by Jean-Philippe Lang almost 10 years ago

  • Status changed from Needs feedback to Closed

I'm closing it. Please open a new ticket if you find another case that breaks.

Actions #5

Updated by Toshi MARUYAMA almost 10 years ago

  • Related to Defect #16270: Patch not working as expected from #16161 in r12491 added
Actions

Also available in: Atom PDF