Defect #16472

Browser translation missing public area under Linux

Added by Rob Jens over 7 years ago. Updated over 7 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Translations
Target version:-
Resolution:Duplicate Affected version:

Description

$ ruby script/about

Environment:
Redmine version 2.3.4.stable
Ruby version 2.1.0-p0 (2013-12-25) [x86_64-linux]
Rails version 3.2.13
Environment production
Database adapter Mysql2

The problem is best illustrated by the provided screenshot. I've found no reference only about this particular problem, besides that there is 1 site which also displays this particular way for me.

Do note that this does not happen on any windows browser that is viewing the login portal: the problem is exclusively Linux and the way Linux browsers (Chrome/Firefox) probably "tell" which language they are using.

Obviously (since displayed correctly under Windows) there is nothing wrong with the translation files.

redmine_browser_translation_linux_bug.png (32.7 KB) Rob Jens, 2014-03-31 10:56


Related issues

Duplicates Redmine - Defect #12900: Template::Error (translation missing: en.date.formats.def... Needs feedback

History

#1 Updated by Toshi MARUYAMA over 7 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Redmine i18n does not depend on browser.
It seems you did not clear cache.
See #13520#note-12.

#2 Updated by Toshi MARUYAMA over 7 years ago

  • Duplicates Defect #12900: Template::Error (translation missing: en.date.formats.default) added

Also available in: Atom PDF