Defect #17484

Custom fields added to "spent time" don't show in context menu

Added by Roland Giesler over 4 years ago. Updated about 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Time tracking
Target version:2.6.0
Resolution:Fixed Affected version:2.3.2

Description

I have added a custom field to "spent time" as shown in the attached file.

!Screenshot from 2014-07-16 16:46:19.png!

I also have a custom field in "issues" as shown in the next attached file.

When I right click the issue in the list, I get a context menu which allow easy setting of the fields. I can tick something invoiced or not. See the next attachment.

However, when I right click the detail of "spent time", the menu doesn't show all the fields and also not the custom field. Se the fourth attachment.

This seems to be a defect, but it could be by design. If it is by design, then I'll change this to a feature request. However, in either case, this cannot be to difficult to fix or what?

Thank you!

Screenshot from 2014-07-16 16_46_19.png - custom field added to spent time (15.9 KB) Roland Giesler, 2014-07-16 16:48

Screenshot from 2014-07-16 16_50_28.png - custom field added to issues (23.6 KB) Roland Giesler, 2014-07-16 16:50

Screenshot Issues.png - custom field appears in issues right click menu (73 KB) Roland Giesler, 2014-07-16 17:09

Screenshot Spent Time.png - custom field doesn't appear in spent time right click menu (100 KB) Roland Giesler, 2014-07-16 17:14

Associated revisions

Revision 13335
Added by Jean-Philippe Lang about 4 years ago

Add time entries custom fields to the context menu for quick bulk edit (#17484).

Revision 13338
Added by Toshi MARUYAMA about 4 years ago

fix test failure on Ruby 1.8.7 PostgreSQL (#17484)

History

#1 Updated by Jean-Philippe Lang about 4 years ago

  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang
  • Target version set to 2.6.0
  • Resolution set to Fixed

Added in r13335.

#2 Updated by Roland Giesler about 4 years ago

Great! Thank you!

#3 Updated by daisyflowers878 jhon about 4 years ago

  • File 38.jpg added

#4 Updated by Jean-Philippe Lang about 4 years ago

  • File deleted (38.jpg)

Also available in: Atom PDF