Defect #19419

MinGW Ruby 2.2: NameError: uninitialized constant ActionView::Helpers::ActiveModelHelper

Added by j j over 2 years ago. Updated about 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Wont fix Affected version:

Description

I'm setting up to my computer
I'm at Step 5 - Session store secret generation
when i type
bundle exec rake generate_secret_token
then error like:

rake aborted!
Name error: uninitialized constant ActionView::Helpers::ActionModeHelper
C:/Ruby22/redmine/config/application.rb:5:in '<top<required>>'
C:/Ruby22/redmine/Rakefile :5:in 'require'
C:/Ruby22/redmine/Rakefile :5:in '<top<required>>'
LoadError: cannot load such file -- actionpack-action_caching
C:/Ruby22/redmine/config/application.rb:5:in '<top<required>>'
C:/Ruby22/redmine/Rakefile :5:in 'require'
C:/Ruby22/redmine/Rakefile :5:in '<top<required>>'
<See full trace by running task with --trace>

You can see clearly in my attached file

Capture.PNG (36.6 KB) j j, 2015-03-19 08:39


Related issues

Related to Redmine - Defect #19952: Redmine is in error with Fedora 22 Closed
Duplicated by Redmine - Defect #20285: Redmine installation is not working : NameError: uninitia... Closed

Associated revisions

Revision 14542
Added by Toshi MARUYAMA over 2 years ago

Gemfile: remove loofah definition (#16962, #19419)

actionpack 4.2 depends on loofah.

History

#1 Updated by Toshi MARUYAMA over 2 years ago

  • Category deleted (Wiki)

#2 Updated by Toshi MARUYAMA over 2 years ago

  • Subject changed from Error when installing redmine to Mingw Ruby 2.2: NameError: uninitialized constant ActionView::Helpers::ActiveModelHelper
  • Status changed from New to Confirmed

#3 Updated by Toshi MARUYAMA over 2 years ago

$ ruby --version
ruby 2.2.1p85 (2015-02-26 revision 49769) [x64-mingw32]

#4 Updated by Toshi MARUYAMA over 2 years ago

$ rake -T
rake aborted!
LoadError: cannot load such file -- nokogiri/nokogiri
c:/workdir/hg-workdir/REDMINE/all/config/application.rb:5:in `<top (required)>'
c:/workdir/hg-workdir/REDMINE/all/Rakefile:5:in `<top (required)>'
LoadError: cannot load such file -- nokogiri/2.2/nokogiri
c:/workdir/hg-workdir/REDMINE/all/config/application.rb:5:in `<top (required)>'
c:/workdir/hg-workdir/REDMINE/all/Rakefile:5:in `<top (required)>'
(See full trace by running task with --trace)

#6 Updated by Toshi MARUYAMA over 2 years ago

  • Subject changed from Mingw Ruby 2.2: NameError: uninitialized constant ActionView::Helpers::ActiveModelHelper to MinGW Ruby 2.2: NameError: uninitialized constant ActionView::Helpers::ActiveModelHelper

It seems because nokogiri does not support MinGW Ruby 2.2.
https://github.com/sparklemotion/nokogiri/issues/1256

Depending:

actionpack (4.2.1) -> rails-html-sanitizer (~> 1.0, >= 1.0.1) -> loofah (~> 2.0) -> nokogiri (>= 1.5.9)

#7 Updated by Toshi MARUYAMA over 2 years ago

  • Status changed from Confirmed to Closed
  • Resolution set to Invalid

We cannot do anything.
I have updated RedmineInstall to ver. 235.

#8 Updated by Toshi MARUYAMA over 2 years ago

  • Related to Defect #19952: Redmine is in error with Fedora 22 added

#9 Updated by Toshi MARUYAMA over 2 years ago

  • Related to deleted (Defect #19952: Redmine is in error with Fedora 22)

#10 Updated by Toshi MARUYAMA over 2 years ago

  • Related to Defect #19952: Redmine is in error with Fedora 22 added

#11 Updated by Toshi MARUYAMA over 2 years ago

  • Duplicated by Defect #20285: Redmine installation is not working : NameError: uninitialized constant ActionView::Helpers::ActiveModelHelper added

#12 Updated by Toshi MARUYAMA about 2 years ago

  • Resolution changed from Invalid to Wont fix

Also available in: Atom PDF