Defect #22162

Workflow - Tracker/Role is not "project" specific

Added by Markus May over 5 years ago. Updated over 5 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues workflow
Target version:-
Resolution:Duplicate Affected version:

Description

We do have several different workflows established for different projects. Since most of our guys here do have differrent roles in different projects, the workflow feature does not seem to work correctly. We still see Ticket Status, which are not used in the workflow for the role PRJ_NAME-Manager (just to make it easier, the PRJ_NAME is used in the Rolename).

I have tried it the other way around and added all Status to a Role which I do have as well (Manager), and now I do see all Status in the Ticket, even though I am not having the role "Manager" in this project.

Could be, that this is related to #20384.

We are using still:

Environment:
  Redmine version                          2.3.0.stable
  Ruby version                             1.9.2 (x86_64-linux)
  Rails version                            3.2.13
  Environment                              production
  Database adapter                         PostgreSQL
Redmine plugins:
  parent_issue_filter                      1.0.1
  redmine_ckeditor                         1.0.16
  redmine_people                           0.1.8
  redmine_tagging                          0.0.1

Related issues

Duplicates Redmine - Defect #11625: Administrator Does Not Follow Workflow For Project Closed

History

#1 Updated by Markus May over 5 years ago

Just for clarification. During my tests, I assigned all Status to the user Manager, but in the project I am testing, I do not have this role. Therefor it looks like the role is not determined from the project, but all roles belonging to my users are used. This is IMHO plainly wrong.

#2 Updated by Markus May over 5 years ago

Looks like this is because I am also registered as "admin". I guess, that this is the cause. Can anybody prove this?

#3 Updated by Toshi MARUYAMA over 5 years ago

  • Status changed from New to Closed
  • Priority changed from High to Normal
  • Resolution set to Duplicate

Duplicate of #11625.

#4 Updated by Toshi MARUYAMA over 5 years ago

  • Duplicates Defect #11625: Administrator Does Not Follow Workflow For Project added

Also available in: Atom PDF