Project

General

Profile

Actions

Defect #11625

closed

Administrator Does Not Follow Workflow For Project

Added by William Roush over 11 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Permissions and roles
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Invalid
Affected version:

Description

Alright fairly simple, I have a few roles:

  • Manager
  • Developer
  • Technician

Developers have additional workflow:
"Pending QA Deployment" > "Deployed to QA" > "Passed QA", available for the "Developer" and "Manager" roles.

Technician have the default workflow.

For some reason while logged in as an Admin on a project I'm given Technician access to, I am given the developer workflow!

This is a bit odd, anyone got ideas?


Files

Tech_Bug_1.PNG (60.5 KB) Tech_Bug_1.PNG William Roush, 2012-08-13 15:54
Tech_Bug_2.PNG (43.5 KB) Tech_Bug_2.PNG William Roush, 2012-08-13 15:54

Related issues

Has duplicate Redmine - Defect #22162: Workflow - Tracker/Role is not "project" specificClosed

Actions
Actions #1

Updated by Jean-Philippe Lang over 11 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

I'm closing it because administrators can apply any status transition given to any role, by design. See #2323.

Actions #2

Updated by William Roush over 11 years ago

Jean-Philippe Lang wrote:

I'm closing it because administrators can apply any status transition given to any role, by design. See #2323.

But what about projects where that workflow is invalid? No one in that project has that workflow, so no one can transition a ticket set to "Pending QA Deployment", which is kind of a workaround for #1853.

Actions #3

Updated by William Roush over 11 years ago

However, I still cannot go from "New" to "Deployed to QA" or "Passed QA" as those are globally invalid transitions, so neither are all options available.

Actions #4

Updated by Toshi MARUYAMA almost 8 years ago

  • Has duplicate Defect #22162: Workflow - Tracker/Role is not "project" specific added
Actions

Also available in: Atom PDF