Feature #22884

Better mean for "Assignee" and best practice

Added by Fabrizio Sebastiani about 4 years ago. Updated about 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:

Description

how the Assignee field shall be intended best?

  1. The person/group that 'has in charge' the issue, in general, referring to what is written typically into the Description field. In this scenario The Assignee field is not needed to be changed often, at every iteration. However the Assignee is not always the person/group that is expected to reply/do something about that issue.
  2. The person/group that is currently expected to "do something" on that issue, that is the person to who the issue is currently locked; in this scenario the Assingee is needed to be changed (almost) at every iteration, tipically together Status field; this in order to notify that he/she have to do something or reply.

Advantages/Disadvantages:

  1. Scenario:
    1. Adv: change Assignee rarely
    2. Dis: not easy for a person to query "all issues on which I shall do something"
  2. Scenario:
    1. Adv: every person immediately get list of issues on which he/she needs to do something: simply query "all issues assigned to me".
    2. Dis: Assingee needs to be changed often, at every iteration (boring, can be forget...)
Both scenario seems reasonable to me; my questions:
  • which scenario is best?
  • is there some side effect to use one of them? Which one?

Thank you.

History

#1 Updated by Toshi MARUYAMA about 4 years ago

  • Status changed from New to Closed

I think your description is more suitable in forum "Open discussion" than this issue tracker.

Also available in: Atom PDF