Project

General

Profile

Actions

Defect #24092

closed

bundler error: selenium-webdriver requires Ruby version >= 2.0.

Added by Tatsuya Saito almost 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Gems support
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Fixed
Affected version:

Description

Error message encountered when running bundle install with Redmine v3.3.1 and Ruby 1.9.3.

Gem::InstallError: selenium-webdriver requires Ruby version >= 2.0.
An error occurred while installing selenium-webdriver (3.0.0), and Bundler cannot continue.
Make sure that `gem install selenium-webdriver -v '3.0.0'` succeeds before bundling.

Evironment:

Environment:
  Redmine version                3.3.1.stable
  Ruby version                   1.9.3-p327 (2012-11-10) [x86_64-darwin11.4.2]
  Rails version                  4.2.7.1
  Environment                    production
  Database adapter               Mysql2
SCM:
  Subversion                     1.7.17
  Mercurial                      3.0
  Git                            1.9.3
  Filesystem                     
Redmine plugins:
  no plugin installed


Files

patch.diff (434 Bytes) patch.diff Tatsuya Saito, 2016-10-18 17:29
Actions #1

Updated by Tatsuya Saito almost 8 years ago

I create and attach a patch of Gemfile like r15274 .

Actions #2

Updated by Toshi MARUYAMA almost 8 years ago

  • Category set to Gems support
  • Target version set to 3.2.5
Actions #3

Updated by Holger Just over 7 years ago

This was fixed in r15915.

Actions #4

Updated by Tatsuya Saito over 7 years ago

  • Status changed from New to Resolved

Holger Just wrote:

This was fixed in r15915.

Thanks information :)
I checked to fix this issue on trunk.

Actions #5

Updated by Toshi MARUYAMA over 7 years ago

  • Status changed from Resolved to Closed
  • Resolution set to Fixed

Fixed by r15946 and r15947.

Actions

Also available in: Atom PDF