Defect #24599

Upgrade Redmin 3.2.0 to 3.3.1

Added by PRASHANT Koparde 11 months ago. Updated 11 months ago.

Status:ClosedStart date:
Priority:UrgentDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Invalid Affected version:

Description

Hi,

Please let me know steps to upgrade Redmin 3.2.0 to 3.3.1 version, Unable to upgrade redmin 3.2.0 to 3.3.1,Giving below mentioned errors,

Gem::InstallError: public_suffix requires Ruby version >= 2.0.

History

#1 Updated by Jan Niggemann (redmine.org team member) 11 months ago

  • Status changed from New to Closed
  • Resolution set to Invalid

Please ask questions on the forums

#2 Updated by Toshi MARUYAMA 11 months ago

  • Description updated (diff)

#3 Updated by Adrian Klaver 11 months ago

Same issue though going from 3.2.3 to 3.2.4.

The Redmine site says:
http://www.redmine.org/projects/redmine/wiki/RedmineInstall#Requirements

3.2, 3.1 ruby 1.9.33, 2.0.02, 2.1, 2.21 Rails 4.20

I have:
aklaver@arkansas:~/redmine-3.2.4$ ruby --version
ruby 1.9.3p484 (2013-11-22 revision 43786) [x86_64-linux]

I get:

Gem::InstallError: public_suffix requires Ruby version >= 2.0.
An error occurred while installing public_suffix (2.0.4), and Bundler cannot continue.
Make sure that `gem install public_suffix -v '2.0.4'` succeeds before bundling.

aklaver@arkansas:~/redmine-3.2.4$ gem install --install-dir vendor/bundle/ruby/1.9.1/gems/ public_suffix -v '2.0.4'
Fetching: public_suffix-2.0.4.gem (100%)
ERROR: Error installing public_suffix:
public_suffix requires Ruby version >= 2.0.

So either the requirements are wrong or the wrong version of public_suffix is being shipped.
FYI there was no such problem with 3.2.3 on same machine.

#4 Updated by Toshi MARUYAMA 11 months ago

Adrian Klaver wrote:

Same issue though going from 3.2.3 to 3.2.4.

I think it is fixed by r15947.

ruby 1.9.3p484 (2013-11-22 revision 43786) [x86_64-linux]

Your ruby is too old.

#5 Updated by Adrian Klaver 11 months ago

How can it be too old if it meets the requirements here:

http://www.redmine.org/projects/redmine/wiki/RedmineInstall#Requirements

In particular that 3.2.3 worked fine. If a minor release changes the base language requirement I would not call that minor and it should not happen. If it does it should loudly called out.

So did the Ruby version change for 3.2.x?
If so the requirements page needs to be updated to reflect that.

#6 Updated by Toshi MARUYAMA 11 months ago

I have added Ruby community announcement link which support for Ruby 1.9.3 and 2.0 has ended.
RedmineInstall

#7 Updated by Go MAEDA 11 months ago

Toshi MARUYAMA wrote:

I think it is fixed by r15947.

Adrian Klaver, probably the problem you have reported has been fixed for upcoming Redmine 3.2.5 in r15947.

Could you try the following steps?

  1. Download updated version of Gemfile from http://www.redmine.org/projects/redmine/repository/entry/branches/3.2-stable/Gemfile
  2. Replace Gemfile on your Redmine 3.2.4 installation with the one you downloaded
  3. run bundler

#8 Updated by Adrian Klaver 11 months ago

Toshi MARUYAMA wrote:

I have added Ruby community announcement link which support for Ruby 1.9.3 and 2.0 has ended.
RedmineInstall

That is helpful, but it does not address whether Redmine is still supporting 1.9.3 and 2.0. As it stands now, with reference to the requirements page, those versions are supported by Redmine. If Redmine indeed is not going to support those versions then the requirements page needs to be changed to reflect that. Though as I previously stated, doing that on a minor release to an existing series does not seem to be the way to go about it.

Go MAEDA wrote:

Adrian Klaver, probably the problem you have reported has been fixed for upcoming Redmine 3.2.5 in r15947.

Could you try the following steps?

  1. Download updated version of Gemfile from http://www.redmine.org/projects/redmine/repository/entry/branches/3.2-stable/Gemfile
  2. Replace Gemfile on your Redmine 3.2.4 installation with the one you downloaded
  3. run bundler

Went through the steps above and it worked. I have a functioning site running 3.2.4 using Ruby 1.93. Thanks.

Also available in: Atom PDF