Feature #26553

Overly restricted number of ReST results

Added by Michael Gerz over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:REST API
Target version:-
Resolution:Duplicate

Description

Currently, ReST queries are limited to 100 elements.

This makes it impossible to, e.g., retrieve all users in one query.

Given today's computing power, please check whether the limit can be lifted.

A proposal is given in the attached patch.

limit-patch.diff Magnifier (430 Bytes) Michael Gerz, 2017-07-27 17:46


Related issues

Duplicates Redmine - Patch #16069: Allow configuration of API limit instead of hardcoding at... New

History

#1 Updated by Toshi MARUYAMA over 2 years ago

  • Tracker changed from Patch to Feature
  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #16069.

#2 Updated by Toshi MARUYAMA over 2 years ago

  • Duplicates Patch #16069: Allow configuration of API limit instead of hardcoding at 100 added

Also available in: Atom PDF