Defect #27043

SVN repos with spaces allow for browsing but not file viewing

Added by Oliver Robson about 5 years ago.

Status:NewStart date:
Priority:NormalDue date:
Assignee:-% Done:


Target version:-
Resolution: Affected version:3.2.5


Our Subversion repository naming structure incorporates spaces in it (http://some.url/svn/repo with spaces/), and it seems this is not working perfectly in Redmine. I can see the files within the repository, however if I try and view a file or the diff of a file, I get a "404 The entry or revision was not found in the repository.". If I try the same thing with a different repository with no spaces in the name, it works as I believe it should (can view / diff files). Interestingly, if I go to a specific revision and 'View differences' it will do a diff of all of the changes in that revision perfectly fine, it's only upon diffing / viewing a single file that it fails.

I have tried replacing the spaces with %20, however this stops me being able to browse the repo at all. I have tried putting the repo string in quotes, however this is not accepted by Redmine as quotes are considered an invalid character in that box.

Having a space in a file name doesn't cause any issues with regards to viewing / diffing, it's just with the repo itself.

The resolution in #7505 shows the repo browsing to be working as intended (like it is for me), however upon attempting to view those files in Redmine is where the issue appears.

Related issues

Related to Redmine - Defect #7505: Subversion: Repository URL with space not handled correctly Closed 2011-01-31


#1 Updated by Toshi MARUYAMA about 5 years ago

  • Related to Defect #7505: Subversion: Repository URL with space not handled correctly added

Also available in: Atom PDF