Defect #30716

latest version of xpath gem need ruby 2.3

Added by Tigergm Wu over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Ruby support
Target version:-
Resolution:Duplicate Affected version:4.0.1

Description

When bundle, the latest xpath which resolved to capybara gem requires higher Ruby version.
Please check and update it. Thanks.

Gem::InstallError: xpath requires Ruby version >= 2.3.
An error occurred while installing xpath (3.2.0), and Bundler cannot continue.
Make sure that `gem install xpath -v '3.2.0' --source 'https://rubygems.org/'` succeeds before bundling.

In Gemfile:
  capybara was resolved to 2.18.0, which depends on
    xpath

Related issues

Duplicates Redmine - Defect #30114: Installing xpath with Bundler fails in Ruby <=2.2 Closed

History

#1 Updated by Tigergm Wu over 2 years ago

Before, the xpath 3.1.0 should work under the Ruby 2.2 version.

#2 Updated by Tigergm Wu over 2 years ago

  • Status changed from New to Resolved

Sorry. May it's a mistake. I bundled in one new enviroment and it succeeded.

#3 Updated by Go MAEDA over 2 years ago

  • Duplicates Defect #30114: Installing xpath with Bundler fails in Ruby <=2.2 added

#4 Updated by Go MAEDA over 2 years ago

  • Status changed from Resolved to Closed
  • Resolution set to Duplicate

Closing as a duplicate of #30114.

I also observed the error a few times but I cannot reproduce it for now.

Also available in: Atom PDF