Project

General

Profile

Actions

Defect #31587

closed

Time Entries REST API user_id parameter doesn't work

Added by Serhiy Valchuk over 4 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
REST API
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Cant reproduce
Affected version:

Description

I'm trying to use Time Entries REST API and it works as expected except user_id parameter.

When I tried to get time entries https://myredmine/time_entries.json?key=mykey&from=2019-06-01&to=2019-06-30&limit=5&user_id=5 I'm getting time entries of all existing users.

Any suggestions?

Actions #1

Updated by Go MAEDA about 4 years ago

  • Status changed from New to Needs feedback

I cannot reproduce the issue with Redmine 4.0.5.devel.19345. The following request returns time entries of user_id 2.

curl 'http://redmine-trunk.test/time_entries.json?from=2000-01-01&to=2019-12-31&user_id=2'
Actions #2

Updated by Go MAEDA about 1 month ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Cant reproduce
Actions

Also available in: Atom PDF