Defect #31937

HTML-Tags are not interpreted correctly / removed from the Ticket.

Added by Dominik Kro almost 2 years ago. Updated over 1 year ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Email receiving
Target version:-
Resolution:Invalid Affected version:4.0.4

Description

Environment:
Redmine version 4.0.4.stable
Ruby version 2.6.3-p62 (2019-04-16) [x86_64-linux]
Rails version 5.2.3
Environment production
Database adapter PostgreSQL
Mailer queue ActiveJob::QueueAdapters::AsyncAdapter
Mailer delivery smtp
SCM:
Git 2.17.1
Filesystem
Redmine plugins:
redmine_ckeditor 1.2.2
redmine_image_clipboard_paste 3.3.0

Hi all,

I've got a problem with my redmine configuration. I'm fetching E-Mails through IMAP and rake. That's working like a charm, but unfortunately the HTML-Tags are not displayed correctly / removed within the ticket. According to the Redmine-Documentation

https://www.redmine.org/projects/redmine/wiki/RedmineReceivingEmails

the mail handler should do that which it dont.
I'm using textile as text-editor.

Could you help me with that?

Thanks in advance!

Dominik

mailtags.png (10.7 KB) Dominik Kro, 2019-08-22 16:02

mail_handler_controller.rb Magnifier (1.43 KB) Dominik Kro, 2019-08-22 16:06

mail_handler.rb Magnifier (20.7 KB) Dominik Kro, 2019-08-22 16:06

History

#1 Updated by Sven Vogt almost 2 years ago

Hi all,

I have the same problem. I'm also working with textile.

Environment:
Redmine version 4.0.4.stable
Ruby version 2.5.5-p157 (2019-03-15) [x64-mingw32]
Rails version 5.2.3
Environment production
Database adapter Mysql2
Mailer queue ActiveJob::QueueAdapters::AsyncAdapter
Mailer delivery smtp

3 days ago, it worked correctly. Since that time, I installed the following plugins:
  • redmine_ckeditor (was temporarily active for testing in a test-project, but switched then back to textile)
  • redmine_issue_dynamic_edit
  • redmine_recurring_tasks
  • redmine_auto_assign_group
  • redmine_per_project_formatting-0.1.0 (which I have meanwhile uninstalled)

Can someone help me?

Thanks, Sven

#2 Updated by Go MAEDA almost 2 years ago

Could you test again after uninstalling all plugins?

#3 Updated by Dominik Kro over 1 year ago

  • Status changed from New to Resolved

Hello again,

Thanks to Go MAEDA, the problem is the redmine_ckeditor plugin.
Uninstalled the plugin now it's working.

Best regards,
Dominik

#4 Updated by Go MAEDA over 1 year ago

  • Status changed from Resolved to Closed
  • Resolution set to Invalid

Thank you for your feedback. I am closing this issue.

Also available in: Atom PDF