Defect #32644

配置renmine时,无法识别renmine数据库

Added by jiankang chen 9 months ago. Updated 9 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Ruby support
Target version:-
Resolution:Invalid Affected version:4.0.5

Description

错误详情:
C:\redmine>set RAILS_ENV=production

C:\redmine>rake db:migrate
rake aborted!
ActiveRecord::NoDatabaseError: Unknown database 'redmine'

Caused by:
Mysql2::Error: Unknown database 'redmine'

Tasks: TOP => db:migrate
(See full trace by running task with --trace)

数据库也建立了:
database.yml也配置:
production:
adapter: mysql2
database: redmine
host: localhost
username: root
password: ""
encoding: utf8

求大神指教

History

#1 Updated by Go MAEDA 9 months ago

  • Status changed from New to Closed
  • Resolution set to Invalid

Please use forums for questions. Issues are used to report a bug, suggesting a new feature, or submitting a patch. Reading How to request help may be helpful for you.

Also available in: Atom PDF