Feature #34762

Display more detailed error message when attempting to import malformed CSV file

Added by Go MAEDA 8 months ago. Updated 8 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Importers
Target version:4.2.0
Resolution:Fixed

Description

Currently, the error message when attempting to import a malformed CSV file is too simple, just says "The file is not a CSV file or does not match the settings below". So it is difficult to identify problems with the CSV file.

The attached patch adds an exception message from Ruby's CSV class. It makes it much easier to debug the cause of importing error.

detailed-error.png (110 KB) Go MAEDA, 2021-02-18 11:12

detailed-error-when-csv-is-malformed.patch Magnifier (38.4 KB) Go MAEDA, 2021-02-18 11:13

Associated revisions

Revision 20756
Added by Go MAEDA 8 months ago

Display more detailed error message when attempting to import malformed CSV file (#34762).

Patch by Go MAEDA.

History

#1 Updated by Go MAEDA 8 months ago

  • Target version set to 4.2.0

Setting the target version to 4.2.0.

#2 Updated by Go MAEDA 8 months ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA
  • Resolution set to Fixed

Committed the patch.

Also available in: Atom PDF