Feature #35216

Create/Update custom fields via API

Added by Luny Luny 9 months ago. Updated 9 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:REST API
Target version:-
Resolution:Duplicate

Description

To maintain my custom fields I would like to update the values with a job using the API

PUT http://redmine.org/custom_fields/8
        <id>8</id>
        <name>ApiTestField</name>
        <customized_type>issue</customized_type>
        <field_format>list</field_format>
        <regexp></regexp>
        <min_length/>
        <max_length/>
        <is_required>false</is_required>
        <is_filter>false</is_filter>
        <searchable>false</searchable>
        <multiple>false</multiple>
        <default_value></default_value>
        <visible>true</visible>
        <possible_values type="array">
            <possible_value>
                <value>1</value>
                <label>1</label>
            </possible_value>
            <possible_value>
                <value>2</value>
                <label>2</label>
            </possible_value>
            <possible_value>
                <value>3</value>
                <label>3</label>
            </possible_value>
            <possible_value>
                <value>4</value>
                <label>4</label>
            </possible_value>
            <possible_value>
                <value>5</value>
                <label>5</label>
            </possible_value>
            <possible_value>
                <value>5</value>
                <label>5</label>
            </possible_value>
            <possible_value>
                <value>6</value>
                <label>6</label>
            </possible_value>
        </possible_values>
        <trackers type="array"></trackers>
        <roles type="array"></roles>

Related issues

Duplicates Redmine - Feature #9664: CRUD operations for "custom field definitions" (not setti... New 2011-11-25

History

#1 Updated by Go MAEDA 9 months ago

  • Duplicates Feature #9664: CRUD operations for "custom field definitions" (not setting custom fields on issues!) added

#2 Updated by Go MAEDA 9 months ago

  • Category changed from Custom fields to REST API
  • Status changed from New to Closed
  • Resolution set to Duplicate

Thank you for suggesting the feature but I just found #9664.

Closing this issue as a duplicate of #9664.

Also available in: Atom PDF