Project

General

Profile

Actions

Feature #3546

closed

"Related issues" should be tracked in Ticket History

Added by Tobias Roeser almost 15 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
Normal
Category:
Issues
Target version:
-
Start date:
2009-06-26
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

Changes in ticket relations should be tracked in the ticket history.

Benefits:
  • (obviously) one can track any change in ticket relations
  • watchers and ticket owners will be notified, when ticket relations change
  • (nice to have, maybe another ticket) one gets notified when blockers were closed

Related issues

Is duplicate of Redmine - Feature #1005: Add the addition/removal/change of related issues to the historyClosedJean-Philippe Lang2008-04-07

Actions
Actions #1

Updated by Tobias Roeser almost 15 years ago

  • Assignee set to Jean-Philippe Lang
Actions #2

Updated by Paulo Santos over 14 years ago

+1

Actions #3

Updated by Manmathan Kumar over 14 years ago

We really miss getting email notification when related (blocked by, follows) issues change status to closed.

Any time frame for implementing this?

Actions #4

Updated by Alain V. almost 14 years ago

This is important. To be able to track when you (de)relate an issue.

Actions #5

Updated by Alain V. almost 14 years ago

I guess same ticket than #1005

Actions #6

Updated by Tobias Roeser over 13 years ago

I'm willing to create a patch that adds this feature. Can someone give me a hint where to start. E.g. which file or function to look first. I'm new to Redmine/Ruby development, btw.

Actions #7

Updated by Jean-Philippe Lang over 13 years ago

Deleting an issue attachment is logged in the history.
So you may want to look at Issue#attachment_removed: source:/trunk/app/models/issue.rb@4263#L771
This is a callback and it's called because of :after_remove => :attachment_removed option on the attachments association.

Actions #8

Updated by Jean-Philippe Lang over 13 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

BTW, I close this ticket as a dup of #1005 that was open before.

Actions

Also available in: Atom PDF