Project

General

Profile

Actions

Feature #39500

closed

Change the default notification option for users to "Only for things I watch or I am assigned to"

Added by Go MAEDA 8 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Accounts / authentication
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:

Description

Currently, the default notification option for a new user is "Only for things I watch or I'm involved in" (internal_name: only_my_events) . This sends notifications when any of the following conditions are met.

  • The issue/object is watched by the user
  • The issue is created by the user
  • The issue is assigned to the user

I think the default option should now be "Only for things I watch or I am assigned to" (internal name: only_assigned) which sends notifications when any of the following conditions are met.

  • The issue/object is watched by the user
  • The issue is assigned to the user

This is because Redmine 5.1.0 has an auto watch for newly created issues (#38238) and the option is enabled by default for newly created users, and the behavior of the combination of auto watch and only_my_events is somewhat confusing.

Consider the following scenario:

  1. Admin creates a new user. The user has all auto watches enabled by default, and the email notification option is set to only_my_events
  2. The user creates an issue. Since all auto watches are enabled for the user, they are added as a watcher
  3. The user receives notifications about the issue
  4. The user decides they do not want to receive notifications anymore and unwatches the issue
  5. But the user still receives notifications because the notification option is only_my_events, and they are the author of the issue

If the default notification option is changed from only_my_events to only_assigned, this confusion will be eliminated. Here is a scenario in this case:

  1. Admin creates a new user. The user has all auto watches enabled by default, and the email notification option is set to only_assigned
  2. The user creates an issue. Since all auto watches are enabled for the user, they are added as a watcher
  3. The user receives notifications about the issue
  4. The user decides they do not want to receive notifications anymore and unwatches the issue
  5. The user does not receive notifications anymore because the notification option is only_assigned, and they are no longer a watcher

As illustrated above, in Redmine 5.1, the behavior is more understandable if the notification option defaults to only_assigned.


Files


Related issues

Has duplicate Redmine - Feature #38343: Change the default notification option to "Only for things I watch or I am assigned to"Closed

Actions
Actions #1

Updated by Go MAEDA 8 months ago

The attached patches update the default notification setting from only_my_events to only_assigned and adjust related tests accordingly.

Actions #2

Updated by Go MAEDA 7 months ago

  • Target version set to Candidate for next major release
Actions #3

Updated by Go MAEDA 7 months ago

  • File 0002-Change-the-default-notification-option-from-only_my_.patch added

Improved patch to keep the behavior when `default_notification_option` is not stored in the database in existing installations.

If `default_notification_option` is not stored in the database, `Setting.default_notification_option` returns `only_my_events` in Redmine 5.1 and earlier. The value should not be changed in existing installations even after upgrading Redmine. See #34863#note-16.

Actions #4

Updated by Go MAEDA 7 months ago

  • File deleted (0002-Change-the-default-notification-option-from-only_my_.patch)
Actions #5

Updated by Go MAEDA 7 months ago

  • File deleted (0002-Change-the-default-notification-option-from-only_my_.patch)
Actions #6

Updated by Go MAEDA 7 months ago

Updated 0002-Change-the-default-notification-option-from-only_my_.patch to use Setting.find_or_create_by! in db/migrate/20231113131245_ensure_default_notification_option_is_stored_in_db.rb.

Actions #7

Updated by Go MAEDA 7 months ago

  • Target version changed from Candidate for next major release to 6.0.0

Setting the target version to 6.0.0.

Actions #8

Updated by Go MAEDA 6 months ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA

Committed the patch in r22504.

Actions #9

Updated by Go MAEDA 6 months ago

  • Has duplicate Feature #38343: Change the default notification option to "Only for things I watch or I am assigned to" added
Actions

Also available in: Atom PDF