Project

General

Profile

Actions

Defect #40834

closed

Copy Link generates incorrect link

Added by Bruce Bongo about 1 month ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Affected version:

Description

When using the "Copy Link" button/function in a ticket, a link containing "localhost:3000/" is generated. The hostname is correctly configured. The screenshot is from Redmine 5.0.0, and the issue is reproducible in version 5.1.3 as well.

Regards Bruce


Files

Actions #1

Updated by Holger Just about 1 month ago

  • Status changed from New to Closed

You have to configure your webserver / proxy server to pass on the externally used Host header to the Redmine application. With nginx, you can use something like this, depending on your actual webserver configuration:

proxy_set_header Host $host;

See e.g. https://serverfault.com/a/598269/51320 for some additional considerations.

Actions #2

Updated by Bruce Bongo about 1 month ago

thank you, it solved the problem

Actions

Also available in: Atom PDF