Project

General

Profile

Actions

Defect #4092

closed

Ruby 1.9 - when attempting to change password error raised IOError in MyController#password

Added by trevor trevor over 14 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Accounts / authentication
Target version:
-
Start date:
2009-10-23
Due date:
% Done:

0%

Estimated time:
Resolution:
Cant reproduce
Affected version:

Description

% rails -v
Rails 2.3.4
% ruby -v
ruby 1.9.2dev (2009-10-22 trunk 25436) [x86_64-linux]

when attempting to change password, this error is raised -

IOError in MyController#password
closed stream

/usr/local/lib/ruby/1.9.1/tempfile.rb:261:in `close'
/usr/local/lib/ruby/1.9.1/tempfile.rb:261:in `block in callback'
/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.4/lib/active_support/core_ext/module/attribute_accessors.rb:24:in `call'
/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.4/lib/active_support/core_ext/module/attribute_accessors.rb:24:in `mechanism'
/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.4/lib/active_support/dependencies.rb:219:in `load?'
/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.4/lib/active_support/dependencies.rb:155:in `require'
/web/mysite/webapps/redmine/app/models/repository/cvs.rb:18:in `'
/web/mysite/webapps/redmine/app/controllers/application_controller.rb:34:in `block in '
/web/mysite/webapps/redmine/app/controllers/application_controller.rb:33:in `each'
/web/mysite/webapps/redmine/app/controllers/application_controller.rb:33:in `'
/web/mysite/webapps/redmine/app/controllers/application_controller.rb:21:in `'
/web/mysite/webapps/redmine/app/controllers/my_controller.rb:18:in `'
Actions #1

Updated by Eric Davis over 14 years ago

  • Subject changed from when attempting to change password error raised IOError in MyController#password to Ruby 1.9 - when attempting to change password error raised IOError in MyController#password
Actions #2

Updated by Eric Davis over 13 years ago

  • Status changed from New to Closed
  • Assignee set to Eric Davis
  • Resolution set to Cant reproduce

Just tested this on Ruby 1.9.1-p378 and Ruby 1.9.2-preview3 and I didn't get any errors when changing my password.

Can you test this again and see if you can reproduce this on trunk? Your comment says you are using Ruby 1.9.2dev but your stacktrace says Ruby 1.9.1 and it's coming from the CVS model and not the change password.

Actions

Also available in: Atom PDF