Patch #5110

Trac importer improvement patch

Added by Bryce Nordgren over 12 years ago. Updated almost 10 years ago.

Status:ClosedStart date:2010-03-17
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Importers
Target version:-

Description

Summary

This patch merges the improvements in #2748 with r3597, and also incorporates the suggested change in #2826. To summarize:

  • Improvement: handles numbered lists
  • Improvement: original trac ticket ID is stored in custom field "TracID"
  • Improvement: can modify text in subversion log messages after import, primarily to fix issue numbers if they changed
  • Improvement: the [Image()] macro is recognized and converted.
  • Maintainence: wiki text code reorganized

I tested this patch on an otherwise pristine version of 0.9.3.

Patch production process

The original code improvement to the migration code happened over a year ago and the version on trunk has been edited many times since then. To ensure that all intermediate edits were retained, I did the following:

  1. Checked out r2280 on trunk.
  2. Downloaded the improvements from #2748
  3. Created a patch going from r2280 -> #2748
  4. Checked out HEAD (r3597)
  5. Applied the above patch to head/edited bits.
  6. Added the "image improvements" on #2826.
  7. Created a new patch against trunk r3597 with all improvements (attached).

The final patch and the "new version" of "migrate_from_trac.rake" are attached.

Testing

This work has undergone minimal testing. I can confirm that fixes as late as #4743/r3517 are included in the final version. A few images appeared in my import (where they should be) and nested lists work.

To use

Either apply the attached patch against migrate_from_trac.rake on trunk, or download my modified version.

migrate_from_trac-3597.patch Magnifier - Patch file against migrate_from_trac.rake on trunk r3597 (21.2 KB) Bryce Nordgren, 2010-03-17 22:12

migrate_from_trac.rake.new - Patched migrate_from_trac.rake, with all enhancements included (38.9 KB) Bryce Nordgren, 2010-03-17 22:12


Related issues

Related to Redmine - Patch #5035: Migrate from trac - Errors in wiki formating New 2010-03-10

History

#1 Updated by Bryce Nordgren over 12 years ago

Ugrh. There may be a high degree of overlap between this effort and #5035. #5035 appears to be more comprehensive in terms of wiki formatting, but does not appear to map ticket numbers into the new system or edit the Subversion log messages that reference issues.

#2 Updated by Mike Stupalov over 12 years ago

Many thanks Bryce!

See updated patch in #5035

#3 Updated by Bryce Nordgren over 12 years ago

  • Status changed from New to Resolved

I'm setting the status on this ticket as "resolved" due to Mike's work on #5035.

#4 Updated by Jan Niggemann (redmine.org team member) almost 10 years ago

Closing this, status is resolved since 400 days and more (issue was last updated more than 400 days ago)...

#5 Updated by Jan Niggemann (redmine.org team member) almost 10 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF