Project

General

Profile

Actions

Feature #5869

closed

Issue filters by Group and Role

Added by Eric Kachur almost 14 years ago. Updated almost 14 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Issues
Target version:
Start date:
2010-07-11
Due date:
% Done:

100%

Estimated time:
Resolution:
Fixed

Description

It would be great to be able to create custom queries by groups. I've got groups like "Client A", "Client B", "My Company" etc. and I've created custom queries to search for the issues assigned to either my clients or my company. Unfortunately I have to modify all custom queries each time I add/remove users. It would be much easier just to manage groups and to have filters use them.


Related issues

Related to Redmine - Defect #9132: Filtering by "Assignee's Group" doesn't show issues assigned to the groupClosed2011-08-26

Actions
Is duplicate of Redmine - Feature #2570: Filter on assigned to roleClosed2009-01-23

Actions
Actions #1

Updated by Eric Kachur almost 14 years ago

Or you can add search by "User Role" of the user assigned. This will also allow for more flexible custom queries.

Actions #2

Updated by Eric Davis almost 14 years ago

  • Category changed from Search engine to Issues
  • Status changed from New to Closed
  • Assignee set to Eric Davis
  • Target version set to 1.1.0
  • % Done changed from 0 to 100
  • Resolution set to Fixed

I added a "Member of Group" to the issues filter. This filter will check an issue's assigned to field for users in (or not in) specific groups.

r4077

Actions #3

Updated by Eric Davis almost 14 years ago

  • Subject changed from Allow filters by Group to Issue filters by Group and Role

Also added a "Member of Role" filter in r4078.

Actions

Also available in: Atom PDF