Project

General

Profile

Actions

Defect #6370

closed

UTF-8 BOM only partially hidden

Added by Barnabás Králik almost 14 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Attachments
Target version:
-
Start date:
2010-09-12
Due date:
% Done:

0%

Estimated time:
Resolution:
Cant reproduce
Affected version:

Description

We are using revision r4083.

When displaying a text file (the extension of which is not known by coderay) that is encoded as UTF-8 with standard 3-byte BOM, only the first 2 bytes are cut off and the third byte, bf is rendered as "".

Standard unix xxd outputs the following for the file visible in the attached screen shot:

$:~/aarghr$ head -n3 Parser.fs | xxd
0000000: efbb bf6f 7065 6e20 5379 7374 656d 0d0a  ...open System..
0000010: 6f70 656e 2053 7973 7465 6d2e 586d 6c0d  open System.Xml.
0000020: 0a0d 0a 

Files

Névtelen.png (17.8 KB) Névtelen.png Screenshot showing the problem Barnabás Králik, 2010-09-12 15:31
test-result-r14637.png (14 KB) test-result-r14637.png Go MAEDA, 2015-10-02 03:25

Related issues

Related to Redmine - Feature #2209: MIME type support for repository EntriesClosed2008-11-17

Actions
Actions #1

Updated by Toshi MARUYAMA about 13 years ago

  • Category deleted (Core Plugins)
Actions #2

Updated by Go MAEDA over 8 years ago

No problem in Redmine 3.1.1.devel.14637.
Can we close this?

$ xxd -g1 text-with-bom.txt
0000000: ef bb bf 66 6f 6f 20 62 61 72 20 62 61 7a 0a 0a  ...foo bar baz..
Actions #3

Updated by Go MAEDA over 2 years ago

  • Category set to Attachments
  • Status changed from Needs feedback to Closed
  • Resolution set to Cant reproduce
Actions

Also available in: Atom PDF