Feature #7391

Html link as custom field

Added by Pierre Pretorius almost 10 years ago. Updated over 9 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:UIEstimated time:3.00 hours
Target version:-
Resolution:Duplicate

Description

Currently when you add a custom field you can choose from things like text, boolean, date, etc. I want to add text, but it should display as a link. You will know best how to implement this. Perhaps a check box "display as link" or "do not escape html" but I guess that is risky, perhaps its a different type of custom field.

Thanks,


Related issues

Duplicates Redmine - Feature #5794: URL custom fields Closed 2010-07-01

History

#1 Updated by Pierre Pretorius almost 10 years ago

  • Assignee set to Jean-Philippe Lang

#2 Updated by Kestutis None almost 10 years ago

Test

#3 Updated by Kestutis None almost 10 years ago

  • Assignee changed from Jean-Philippe Lang to Holger Just

Kestutis Naureckas wrote:

Test

None

#4 Updated by Holger Just almost 10 years ago

  • Assignee deleted (Holger Just)

(reverted spam)

#5 Updated by Daniel Martinez over 9 years ago

This can easily be done in about 1 minute.
simply wrap the line that renders the custom_value in the auto_link() function like this:

auto_link(simple_format_without_paragraph(h(show_value(value))))

and you instantly have clickable links

#6 Updated by Etienne Massip over 9 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closed as duplicate of #5794

Also available in: Atom PDF