Defect #7666

Deleting multiple subtasks brokes nested set hierarchy

Added by Dennis Garoufalis almost 11 years ago. Updated almost 8 years ago.

Status:ClosedStart date:2011-02-20
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Database
Target version:-
Resolution: Affected version:1.1.1

Description

Create two subtasks under an issue.
While on the issue list select both subtasks and delete.
Hierarchy is broken, lft and rgt fields have wrong values.

I will be available 24/7 regarding this issue as our company is trying to deploy redmine as a major tool and it is critical to maintain a stable environment.

Great project !

Redmine 1.1.1.stable.4877 (MySQL)

Ruby version 1.8.7 (i486-linux)
RubyGems version 1.3.5
Rack version 1.0
Rails version 2.3.5
Active Record version 2.3.5
Active Resource version 2.3.5
Action Mailer version 2.3.5
Active Support version 2.3.5
Application root /home/redmine_mp
Environment production
Database adapter mysql
Database schema version 20101114115359

studec_patch_ex_parent_task_fields.zip - Patch directory to correctly update lft/rgt values on deleting children (7.9 KB) Contributor STUDEC, 2011-04-26 10:25


Related issues

Related to Redmine - Defect #6579: Tree hierachy being currupted on multiple submissions of ... Closed 2010-10-05

History

#1 Updated by Jean-Philippe Lang almost 11 years ago

Using current trunk, I'm not able to reproduce. Selecting and deleting the 2 children properly updates parent's lft/rgt values.

#2 Updated by Contributor STUDEC over 10 years ago

We had the same problem with the 1.0.1 version of Redmine (we can not use the current trunk for now because of plugins compatibility).

We developed a patch to correct it. In the version 1.0.1 of Redmine, the children are deleted in the wrong order, ordering the "@issues" before the "destroy" of the issues_controller seems fix the problem.

Here is the patch developed by Studec. It is like a plugin, just copy/paste in the plugins directory (vendor/plugins).

Hope it will help.

#3 Updated by liku xiong· about 10 years ago

  • % Done changed from 0 to 20

#4 Updated by liku xiong· about 10 years ago

  • Status changed from New to Resolved

#5 Updated by Toshi MARUYAMA about 10 years ago

  • Status changed from Resolved to New
  • Priority changed from Urgent to Normal
  • % Done changed from 20 to 0

#6 Updated by Toshi MARUYAMA almost 8 years ago

  • Status changed from New to Closed

This issue is too old.
awesome_nested_set implementation changed in Rails2 and Rails3.

Also available in: Atom PDF