Feature #8915

Use *.exe (e.g. hg.exe) for SCM command on Windows

Added by pasquale [:dedalus] over 5 years ago. Updated over 5 years ago.

Status:ReopenedStart date:2011-07-27
Priority:NormalDue date:
Assignee:Toshi MARUYAMA% Done:

0%

Category:SCM
Target version:Candidate for next major release
Resolution:

Description

Since the begin, I have configured my mercurial repos using mercurial_adapter.rb (and not configuration.yml that isn't in use on my server): all have worked fine. But after the upgrade to 1.2.1 I have an error (see bug-in-action.png): I suppose that this error is raised by the double-quotes over hg: if I delete the quote and hit the same command via terminal all work fine.

bug-in-action.png (115 KB) pasquale [:dedalus], 2011-07-27 11:13

History

#1 Updated by Toshi MARUYAMA over 5 years ago

  • Assignee set to Toshi MARUYAMA

#2 Updated by Toshi MARUYAMA over 5 years ago

  • Assignee deleted (Toshi MARUYAMA)

#3 Updated by Toshi MARUYAMA over 5 years ago

  • Status changed from New to Closed
  • Resolution set to Cant reproduce

All SCMs use same logic, such as "svn", "git".
I tested on MingW Ruby, and I don't use Bitnami.
I can't reproduce.

#4 Updated by Toshi MARUYAMA over 5 years ago

  • Subject changed from Repositories error after upgrading from 1.1.2 to 1.2.1 to Windows BItnami: Repositories error after upgrading from 1.1.2 to 1.2.1

#5 Updated by Toshi MARUYAMA over 5 years ago

  • Resolution deleted (Cant reproduce)

#6 Updated by Toshi MARUYAMA over 5 years ago

Try set "hg.exe" in configuration.yml.

#7 Updated by pasquale [:dedalus] over 5 years ago

Toshi MARUYAMA wrote:

Try set "hg.exe" in configuration.yml.

I have installed the mercurial-python release for Windows and not tortoiseHg as suggest in configuration.yml... and I don't want to install tortoiseHg into my server: another choice?

#8 Updated by Toshi MARUYAMA over 5 years ago

  • Status changed from Closed to Reopened

As I described at configuration.yml, "hg.cmd" does not work.

There is only Mercurial Windows installer.
https://bitbucket.org/tortoisehg/thg-winbuild/downloads

#9 Updated by pasquale [:dedalus] over 5 years ago

Toshi MARUYAMA wrote:

There is only Mercurial Windows installer.
https://bitbucket.org/tortoisehg/thg-winbuild/downloads

I have used [1] http://mercurial.selenic.com/release/windows/mercurial-1.9.win32-py2.6.exe until redmine 1.2.1 release, and all work fine (without use of configuration.yml);

Now, with your suggest, I have also installed [2] http://mercurial.selenic.com/release/windows/mercurial-1.9-x86.msi and repos return to work (without use of configuration.yml but mercurial_adapter.rb): in conclusion after redmine release 1.2.1 it seems that I need to install both [1] and [2] to work with repos.

Thanks for your attention: maybe now we can close this bug as Worksforme

#10 Updated by Toshi MARUYAMA over 5 years ago

  • Tracker changed from Defect to Feature
  • Subject changed from Windows BItnami: Repositories error after upgrading from 1.1.2 to 1.2.1 to Use *.exe (e.g. hg.exe) for SCM command on Windows
  • Target version set to 1.3.0

#11 Updated by Toshi MARUYAMA over 5 years ago

  • Assignee set to Toshi MARUYAMA

#12 Updated by alvis lee over 5 years ago

jruby 1.5.6 has error´╝Ü

scm: error during get scm available:
scm: error during get version string:

#13 Updated by Toshi MARUYAMA over 5 years ago

  • Target version changed from 1.3.0 to Candidate for next major release

Also available in: Atom PDF