Defect #9018

Problem configuring subversion SCM

Added by W N over 8 years ago. Updated over 8 years ago.

Status:NewStart date:2011-08-09
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:SCM
Target version:-
Resolution: Affected version:1.2.1

Description

Hi matter how I would configure the svn command it does not work. Allways displays "Scm command not available. Please check settings on the administration panel." If I go to the admin panel I see the command I've put in but there is still red exclamation sign. Can you please provide some feedback how to solve this. I have already tried:
- upgrade of svn to version 1.6.x
- setting PATH in environment.rb
- change SVN_BIN in subversion_adapter.rb and adding stuff for certificates handling
- setting scm_subversion_command in configuration.yml
None of these works....

redmine2.png (48.4 KB) W N, 2011-08-09 16:00

redmine.png (48 KB) W N, 2011-08-09 16:00

History

#1 Updated by W N over 8 years ago

I forgot to say that Redmine is on MySQL, CentOS via httpd.

#2 Updated by Toshi MARUYAMA over 8 years ago

  • Category set to SCM
  • Priority changed from High to Normal

#3 Updated by W N over 8 years ago

with 1.2.0 same setup works perfectly correctly (with default config)

#4 Updated by Nandana Mihindukulasooriya over 8 years ago

I faced the exact same issue after upgrading from 1.0.1 to 1.2.1. Is this a bug in 1.2.1 ? Are there any work around for this ? This has become a show-stopper for us. Thanks.

Best Regards,
Nandana

Also available in: Atom PDF