Defect #9199

Hide the issues in issue list for those users with role's issues visibility set as "created by or assigned to"

Added by Jeremy Jiang almost 11 years ago. Updated over 1 year ago.

Status:Needs feedbackStart date:2011-09-07
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues permissions
Target version:-
Resolution:Cant reproduce Affected version:1.2.0

Description

In Redmine 1.2.0, there are issues visibility setting in "Administration" -> "Roles and permissions" with three options.
All issues
All non private issues
Issues created by or assigned to the user

Assume in a project we create a new role as "External users" and grant this role the issues visibility as "Issues created by or assigned to the user".
The expected behavior should be like that external users can only view the issues created by themselves or assigned to them no matter the issue is public or private.

While the fact is that if the issue is created by internal users and not assigned to external users,
If it is public,
it will still be viewed by external users in issue list, just can not view the contents of that issue.
If it is private,
it will not be displayed for external users even in issue list.

It seems that it makes no sense to let external users see the issues in issue list which he/she can not view the contents, even it is a public issue.

Can it be unified as the second behavior?
Hide those issues "not created by or assigned to" external users in "Issues" tab for them?


Related issues

Related to Redmine - Defect #9227: User with right "Issues created by or assigned to the use... New 2011-09-11

History

#1 Updated by Etienne Massip almost 11 years ago

  • Category set to Issues permissions

#2 Updated by Jeremy Jiang almost 11 years ago

Hi, dear Etienne, I see you have changed the category of this issue.
Do you think it is reasonable? Or, if not (since it may be a minor problem for other people), could you do me the favor to show me how to make such modification?
I guess it should be related to the code to search database according to user's role. But I am newbie to Ruby.
Thank you in advance.

#3 Updated by Etienne Massip almost 11 years ago

I've set a category since you didn't pick one.

BTW, do you have any plugins (please have a look at SubmittingBugs) that could explain this behavior?

#4 Updated by Go MAEDA over 1 year ago

  • Status changed from New to Needs feedback
  • Resolution set to Cant reproduce

I cannot reproduce the issue in the current trunk (r20602). The steps I tried are as follows:

1. Load test fixtures by running bin/rails db:fixtures:load
2. Set "Developer" role's "Issues visibility" to "Issues created by or assigned to the user"
3. Disable "Display subprojects issues on main projects by default" setting
4. Sign in with the account "dlopper"
5. Open "Issues" tab of a public project "eCookbook" project. The role of the user "dlopper" is "Developer" in the project
6. You will see only two issues that are assigned to "dlopper". Other issues are invisible

Also available in: Atom PDF