Plugins Directory » WWPass Redmine authentication

Author: Ochir Abushinov
Website: https://github.com/wwpass/redmine_wwpass_auth
Code repository: https://github.com/wwpass/redmine_wwpass_auth.git
Registered on: 2015-12-03 (about 3 years ago)
Current version: 1.0.0
Compatible with: Redmine 4.0.x, 3.3.x
User ratings:   (0)

WWPass Redmine Plugin that implements a secure authentication based on WWPass technology.

WWPass offers the only solution where you can securely protect your on-line identities from hackers. When a website enables WWPass authentication, you log on without using a username or a password, which means there is nothing for the hacker to steal. Instead you log on using a PassKey™ and an access code. The access code becomes the only ‘password’ that you will ever need to remember.

Your user accounts and personal data are never stored on your PassKey. If your PassKey or your mobile phone were lost or stolen, you are still safe. Your user accounts and data cannot be retrieved without your secret access code. This means that hackers would need to actually have your device and access code to do anything.

The PassKey can be used to provide secure authentication into more than just one organization or application. We’ve designed our authentication solution so that the user can access multiple systems, internal or external, with only one PassKey. No need to try and remember multiple passwords or fumble for the right device to access differing systems.

Since your key is your only access to the system, and since WWPass doesn’t require you to register a name or address for your account, you are completely anonymous to WWPass.

More information at https://www.wwpass.com.

Installation notes

The plugin is installed as any other Redmine Plugin

To start using WWPass authentication plugin with Redmine, you need to register at WWPass Developers website:
https://developers.wwpass.com/auth.

Then you need to issue certificates according to the link below:
https://developers.wwpass.com/documentation/get-started.

Changelog

1.0.0 (2015-12-03)

Compatible with Redmine 4.0.x, 3.3.x.

1.0 (2015-12-03)

Compatible with Redmine 4.0.x.