Domain

Added by Roman Sobol over 9 years ago

How can I "tie" domain to Redmine?

Replies (9)

RE: Domain - Added by David Bauer over 9 years ago

This depends on which server you use and in which configuration it is running, if you use a name-based VirtualHost setup on an Apache Server with mod_passenger for example, you can define a ServerName and ServerAliases in your Apaches httpd.conf.

RE: Domain - Added by Roman Sobol over 9 years ago

Now my Redmine is available at the address example:3000, how can I bind it to the domain project.example.com? (Apache)

RE: Domain - Added by David Bauer over 9 years ago

I recommend to install Phusion Passenger, alternativly you could use ProxyPass and ProxyPassReverse to pass it to example:3000.
This is not Redmine specific, this applies to pretty much any ruby on rails application.

This is how your VirtualHost could look like when using Phusion Passenger:

<VirtualHost *:80>
    ServerName project.example.com
    DocumentRoot /var/www/redmine/public
    PerlLoadModule Apache::Redmine
    RailsEnv production
    RailsBaseURI /
    <Directory /var/www/redmine/public>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        allow from all
    </Directory>
    <Location /sys>
        Order deny,allow
        Deny from all
        Allow from 127.0.0.1
    </Location>

# SVN Stuff from here on
    <Location /svn>
        DAV svn
        SVNParentPath "/var/svn" 
        AuthType Basic
        AuthName redmine
        Require valid-user
        PerlAccessHandler Apache::Authn::Redmine::access_handler
        PerlAuthenHandler Apache::Authn::Redmine::authen_handler
        RedmineDSN "DBI:mysql:database=redmine;host=localhost" 
        RedmineDbUser "redmine" 
        RedmineDbPass "examplepass" 
    </Location>
    <Location /svn-private>
        DAV svn
        SVNParentPath "/var/svn" 
        Order deny,allow
        Deny from all
        <Limit GET PROPFIND OPTIONS REPORT>
            Allow from 127.0.0.1
        </Limit>
    </Location>
</VirtualHost>

RE: Domain - Added by Roman Sobol over 9 years ago

Now when I try to enter in the domain, it throws me on a default page

RE: Domain - Added by Jan from Planio www.plan.io over 9 years ago

Did you install passenger using gem install passenger and passenger-install-apache2-module? Let us know which Linux distribution you are using. In case it's Ubuntu (Debian might work as well), you can have a look at http://wiki.ousli.org/index.php/RedmineUbuntu, or do a Google search for redmine+passenger+[name of your distribution].

Shameless plug: if you don't want to install or host Redmine on your own, you could also try Planio Redmine Hosting. We offer hosted Redmine as a turnkey solution together with unlimited Git & SVN repos, and a couple of extras, ready to use in <5 min. We also import your existing Redmine data. (Disclosure: I work for Planio)

RE: Domain - Added by Roman Sobol over 9 years ago

Sorry, that was my mistake. I have not changed the domain. Now everything works, thanks.

RE: Domain - Added by Roman Sobol over 9 years ago

New question, how to make a default page /projects?

RE: Domain - Added by Roman Sobol over 9 years ago

up

RE: Domain - Added by Felix Schäfer over 9 years ago

1. not possible (or at least not that simple),
2. if the question doesn't fall in the scope of the first question and/or the topic, I'd advise opening a new topic, so that everyone knows at first glance what the problem is.

(1-9/9)