【plantuml】can't use on 3.4.6?

Added by Jianfei Chen 11 months ago

I am using redmine 3.4.6 while is supported by plantuml plugin 0.5.1.

But after I copied the plugin into the folder and add a script into /usr/bin/plantuml. There are several issues

issue one:

when click the plugin configuration page, the error occurs

404
The page you were trying to access doesn't exist or has been removed.

issue two:

because issue one, I can't set the default url of the "plantuml_binary_default", I modified the init.rb in the plugin folder. But where I paste the example code in the wiki, the error occurs:

Error executing the plantuml macro (uninitialized constant PlantumlHelper)

Here is the example code:

{{plantuml(png)
  Bob -> Alice : hello
}}

did I missed something in the installation? Any one successfully intergrated plantuml plugin in the redmine 3.4.6?

Replies (3)

RE: 【plantuml】can't use on 3.4.6? - Added by Bernhard Rohloff 11 months ago

Hallo Jianfei Chen and welcome to the Redmine community!

I think there is something wrong with your plugin installation. If your view isn't loading there might be a problem with your file permissions.
Check if the file app/views/settings/_plantuml.html.erb exists within your plugin folder and if it's readable by the process running Redmine.

I have the plugin installed on 3.4.6 and it works like a charm.

Kind regards,
Bernhard

RE: 【plantuml】can't use on 3.4.6? - Added by Jianfei Chen 11 months ago

thanks. But i double check the file permissions, it's ok. The file _plantuml.html.erb also exists.

but my problem not solved

here is my environment.

![](http://ued.rr.tv/0.5253794924678905Screen%20Shot%202018-09-12%20at%2018.16.13.png)
![](http://ued.rr.tv/0.8138444354194854Screen%20Shot%202018-09-12%20at%2018.19.11.png)

RE: 【plantuml】can't use on 3.4.6? - Added by Mohamed Abdel-Monem 11 months ago

I had exactly the same problem. It was due to bad directory name for the plugin.

I just renamed the directory from plantuml_plugin to plantuml and it was working.

(1-3/3)