Unable to add members to projects

Added by Stewart Ferguson 25 days ago

As administrator, in a project/Settings page, I click "+ New Member". I see the "Loading" box for a moment, then it disappears and nothing else happens. I can't seem to add members to projects.

Things that definatly work:
- LDAP settings
- Adding local users to the server
- Editing an existing member's role
- Creating projects, adding issues, attaching files,

I'm not sure how to troubleshoot this so I'd appreciate if someone has advice.

Here is one log in reaction to clicking "Add Member", but it doesn't show anything abnormal.

root@pluto:~# tail -n 9 /var/log/redmine/default/production.log
Started GET "/projects/a320/memberships/new" for at 2019-11-14 15:50:28 +0100
Processing by MembersController#new as JS
  Parameters: {"project_id"=>"a320"}
  Current user: stew.ferguson (id=7)
  Rendering members/new.js.erb
  Rendered members/_new_form.html.erb (10.0ms)
  Rendered members/_new_modal.html.erb (11.1ms)
  Rendered members/new.js.erb (11.9ms)
Completed 200 OK in 78ms (Views: 8.5ms | ActiveRecord: 35.2ms)

This might have been a consequence of migrating redmine 3.3.1 -> 4.0.1 during a Debian 9 -> 10 host OS upgrade.

If interested, the installation packages were generated using these sources:

The database is:

postgres@pluto:~$ psql redmine_default postgres
psql (11.4 (Debian 11.4-1), server 9.6.12)

However I don't know much about migrations.

Replies (4)

RE: Unable to add members to projects - Added by Stewart Ferguson 19 days ago

Not solved, but at least I have a work-around:

If I simply "Open link in new tab", I get the appropriate page and can add members. It's only the clicking action that doesn't change pages.

I went a step further and using my browser, manually changed

<a class="icon icon-add" data-remote="true" href="/projects/a320/memberships/new">New member</a>

<a class="icon icon-add" href="/projects/a320/memberships/new">New member</a>

Then everything worked well.

I'm glad it's not a database issue. I was worried my database was corrupt. Is this something anyone else can reproduce? If so, we should write a bug.

I can reproduce in Firefox (68.2.0esr) and Chromium (78.0.3404.97).

RE: Unable to add members to projects - Added by Bernhard Rohloff 19 days ago

I can't reproduce your issues. It works fine on my installation so far with Firefox 70.
Perhaps it is a sort of caching problem. Did your browser reload Redmine completely. Just guessing...

Could themes or plugins affect your modals anyhow?

RE: Unable to add members to projects - Added by Mischa The Evil 19 days ago

This might be a problem caused by a CSP policy. See eg. #25207, #31708 and #29405.

RE: Unable to add members to projects - Added by Stewart Ferguson 19 days ago

#31708 looks very similar. Looks like someone had the same issue on 4.0.1 (Just like me) and it's fixed in a newer rev. Will update, thanks.