Redmine Scrumbler plugin

Added by zacky azoulay almost 6 years ago

Hi,

I use bitnami with redmine 1.2.1 on windows 2008

i create some Issues and i can see them in the scrumbler_backlogs

when i try to move them to a Sprints i got an error

the problem that i can see is that i use bitname and the web is http://webname/redmine/scrumbler_backlogs?project_id=test1

if i try o get the Issue from backlog it failed becouse it look in the webname/issues/1

i use the google chrom

thank and regards zacky

Replies (40)

RE: Redmine Scrumbler plugin - Added by Alberto Mendez over 5 years ago

Hi,

Is Scrumbler plugin compatible with Redmine 2.0.0?, does anybody installed succesfully?

Thanks in advance,
Alberto

RE: Redmine Scrumbler plugin - Added by Vincent Mary over 5 years ago

Hi

I am trying to install it on Redmine 2.0.1 / RAILS 3.2.3

It fails. There is a problem with loading the "dispatcher" in init.rb. So I replaced that however now I get

** Invoke db:migrate:plugin (first_time)
** Invoke redmine:plugins:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
rake aborted!
undefined method `named_scope' for #<Class:0x7fab67f11598>
/usr/lib/ruby/gems/1.8/gems/activerecord-3.2.3/lib/active_record/dynamic_matcher                                 s.rb:50:in `method_missing'

Has anyone managed to get this working in Redmine 2?

Thanks

Vincent

RE: Redmine Scrumbler plugin - Added by Vincent Mary over 5 years ago

Hi There

Sorry but I'd really like a hint or 2 ;o)

Have anyone tried to install this on Redmine 2.0.1 please?

Thanks

Regards
Vincent

RE: Redmine Scrumbler plugin - Added by Alberto Mendez over 5 years ago

I am going to try to install it, I will feed back as soon as I have something.
But, ¿has anybody installed already?

RE: Redmine Scrumbler plugin - Added by Vincent Mary over 5 years ago

Hi there

Any luck with this?

Thanks

Vincent

RE: Redmine Scrumbler plugin - Added by Alberto Mendez over 5 years ago

Not at all. We have problems installing it on Redmine 2, so we have discontinued with this plugin unless others can make it works.

Are there any other alternative in order to use SCRUM with Redmine ?

RE: Redmine Scrumbler plugin - Added by Jonas J over 5 years ago

Has anyone tried it with Redmine 1.4.4 and Rails 2.3.14 with Ruby 1.8.7 ?? Does it work?

Thanks in advance,

RE: Redmine Scrumbler plugin - Added by João Nunes almost 5 years ago

Hello, I'm struggling to install, own the Redmine 1.2.2
This is the error displayed:

rake --trace  db:migrate:plugin NAME=redmine_scrumbler RAILS_ENV=production
WARNING: 'require 'rake/rdoctask'' is deprecated.  Please use 'require 'rdoc/task' (in RDoc 2.4.2+)' instead.
    at /usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/rdoctask.rb
WARNING: 'task :t, arg, :needs => [deps]' is deprecated.  Please use 'task :t, [args] => [deps]' instead.
    at /opt/redmine/lib/tasks/email.rake:170
** Invoke db:migrate:plugin (first_time)
** Invoke environment (first_time)
** Execute environment
no such file to load -- ruby-oci8
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `gem_original_require'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `require'
/opt/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:184:in `require'
/opt/redmine/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:217:in `load'
/opt/redmine/config/../vendor/rails/railties/lib/initializer.rb:307:in `load_gems'
/opt/redmine/config/../vendor/rails/railties/lib/initializer.rb:307:in `each'
/opt/redmine/config/../vendor/rails/railties/lib/initializer.rb:307:in `load_gems'
/opt/redmine/config/../vendor/rails/railties/lib/initializer.rb:164:in `process'
/opt/redmine/config/../vendor/rails/railties/lib/initializer.rb:113:in `send'
/opt/redmine/config/../vendor/rails/railties/lib/initializer.rb:113:in `run'
/opt/redmine/config/environment.rb:22
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `gem_original_require'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `require'
/opt/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:182:in `require'
/opt/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:547:in `new_constants_in'
/opt/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:182:in `require'
/opt/redmine/vendor/rails/railties/lib/tasks/misc.rake:4
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:205:in `call'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:205:in `execute'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:200:in `each'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:200:in `execute'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:158:in `invoke_with_call_chain'
/usr/local/lib/ruby/1.8/monitor.rb:242:in `synchronize'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:151:in `invoke_with_call_chain'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:176:in `invoke_prerequisites'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:174:in `each'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:174:in `invoke_prerequisites'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:157:in `invoke_with_call_chain'
/usr/local/lib/ruby/1.8/monitor.rb:242:in `synchronize'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:151:in `invoke_with_call_chain'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:144:in `invoke'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:116:in `invoke_task'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:94:in `top_level'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:94:in `each'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:94:in `top_level'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:133:in `standard_exception_handling'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:88:in `top_level'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:66:in `run'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:133:in `standard_exception_handling'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:63:in `run'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.9.2.2/bin/rake:33
/usr/local/bin/rake:19:in `load'
/usr/local/bin/rake:19
rake aborted!

RE: Redmine Scrumbler plugin - Added by Jan Niggemann (redmine.org team member) almost 5 years ago

no such file to load -- ruby-oci8

Ruby-oci8 is a ruby interface for Oracle databases. Do you use Oracle?

RE: Redmine Scrumbler plugin - Added by João Nunes almost 5 years ago

Yes!
Jan Niggemann wrote:

no such file to load -- ruby-oci8

Ruby-oci8 is a ruby interface for Oracle databases. Do you use Oracle?

RE: Redmine Scrumbler plugin - Added by Paul paul over 4 years ago

Any idea on how to uninstall it on Redmine 2.2? Uninstall fails, saying that the plugin can't be found. The authors of the plugin don't seem to be responding to that issue for over 7 months. Anybody knows what needs to be modified in the uninstall scripts to fix the uninstall issue?
Thanks so much.

RE: Redmine Scrumbler plugin - Added by Jean-Baptiste Barth over 4 years ago

Uninstalling a redmine plugin is pretty easy if the project doesn't provide a canonical way to do that:
  • remove the directory where the plugin is installed (usually plugins/<name_of_the_plugin> in recent redmine versions)
  • undo the changes in the database if they break redmine (meaning you get 500 errors or big stack traces when booting redmine) :
    • first look at migrations : in our case, if I'm right you should be using https://github.com/256MbTeam/Redmine-Scrumbler ; database migrations are in the "db/migrate/" directory :
      • files 1 and 2 are just table additions (you can delete the tables but basically they will just be ignored if you don't, so you don't care)
      • file 3 is a technical trick to remove some entries in a system table, you don't have anything to do
      • file 4 and 5 add columns for tables created in 1/2
      • file 6 adds some custom fields, which actually leads me to the next point
    • then some data might be inserted in standard Redmine tables that may break redmine if the plugin is not installed
      • the incompatibility is due to the fact redmine (actually rails) sometimes try to load dynamically code (ruby classes) depending on the data in tables with a special role ; those tables are recognizable because they have a special column named "type"
      • in this plugin case, I didn't see any evidence that the data inserted might be incompatible with a standard redmine usage ; the plugin just defines some custom fields on "Issue" which stays a standard redmine kind of objects, and does the rest in its own tables

So basically, remove the directory, and optionnally remove tables starting with "scrum" in your database. If that doesn't work, show us the errors you see.

RE: Redmine Scrumbler plugin - Added by Paul paul over 4 years ago

The moment I go to the Issues in a project that previously had the plugin installed, it gives me an Internal Error.

Logs say:

Started GET "/projects/myproject/issues" for 192.168.2.21 at 2013-05-10 12:40:38 -0400
Processing by IssuesController#index as HTML
  Parameters: {"project_id"=>"myproject"}
  Current user: thisuser (id=3)
Completed 500 Internal Server Error in 417ms

ActiveRecord::SubclassNotFound (The single-table inheritance mechanism failed to locate the subclass: 'ScrumblerIssueCustomField'. This error is raised because the column 'type' is reserved for storing the class in case of inheritance. Please rename this column if you didn't intend it to be used for storing the inheritance class or overwrite CustomField.inheritance_column to use another column for that information.):
  app/models/query.rb:1051:in `add_associations_custom_fields_filters'
  app/models/query.rb:361:in `available_filters'
  app/helpers/queries_helper.rb:166:in `build_query_from_params'
  app/helpers/queries_helper.rb:134:in `retrieve_query'
  app/controllers/issues_controller.rb:56:in `index'

RE: Redmine Scrumbler plugin - Added by - - - over 4 years ago

Hello,

I've tried to install the plugin on our BitNami Redmine Stack 1.3.0 but I get the following error when I try to migrate it:

undefined method `application' for Rails:Module

Does anybody have any idea?

RE: Redmine Scrumbler plugin - Added by Alex Shemshurenko over 4 years ago

ive tried to install scrubler.
Ive downloaded it from git.
and ran
rake db:migrate:plugin NAME=redmine_scrumbler
it gave me error "Plugin redmine_scrumbler was not found". i can see redmine_scrumbler folder in redmine plugins folder.
What am i doing wrong and how can i rall back changes on db
if i try "rake redmine:plugins:migrate NAME=redmine_scrumbler VERSION=0 RAILS_ENV=production" , to downgrade db , it gives error "Plugin redmine_scrumbler was not found.".
Please help.

1 2 (26-40/40)