ezFAQ 0.0.2.1 (to be compatible with redmine 0.8.2)

Added by Chaoqun Zou over 8 years ago

Since some users have report a compatibility issue with redmine 0.8.2 and ezFAQ 0.0.2, I make this bug fix release for use with redmine 0.8.2.
And the ezFAQ after 0.2.0 is not compatible with redmine 0.8.2, too. You must wait for redmine 0.8.3 to use ezFAQ 0.2.0.

This 0.0.2.1 version should only run with redmine 0.8.2, if you use redmine before 0.8.2, please try ezFAQ 0.0.2.

Replies (14)

ezfaq vs ezfaq_plugin (RE: ezFAQ 0.0.2.1) - Added by Jochen Kirn over 8 years ago

Hi Chaoqun,

thanks for this neat plugin.
I've installed it using 'git clone git://github.com/zouchaoqun/ezfaq.git'.
Because the plugin has been installed in "<redmine>/vendor/plugins/ezfaq", Error of type 'ActionView::TemplateError (No plugin called 'ezfaq_plugin' - please use the full name of a loaded plugin.)' and such may be thrown.
I've resolved the issue caused by this by replacing all occurances of 'ezfaq_plugin' with 'ezfaq' -> works for me.

I'm on RoR 2.2.2, redmine trunk (r2645)

RE: ezFAQ 0.0.2.1 (to be compatible with redmine 0.8.2) - Added by Chaoqun Zou over 8 years ago

Hi, Jochen
Thanks for your suggestion. Now the plugin must have a relation to its directory name.
And I have mentioned it in the README, but not very clearly, I will change the README soon.
The follow line has indicated that the plugin's directory must be ezfaq_plugin.

1. Copy the plugin directory(ezfaq_plugin) into the vendor/plugins directory

RE: ezFAQ 0.0.2.1 (to be compatible with redmine 0.8.2) - Added by Alexander Kirillov over 8 years ago

Hi Chaoqun,

This version indeed works with redmine 0.8.2.
Thanks a lot.

I've attached lang/ru.yml you may freely use
when distributing your plugin.

I'd also suggest to change all occurrences of FAQ
in the UI into a localized string.

ru.yml Magnifier - Russian L10n (1.72 KB)

RE: ezFAQ 0.0.2.1 (to be compatible with redmine 0.8.2) - Added by Denis Tomashenko over 8 years ago

I think "ЧаВо" is not serious word for serious projects and serious customers. IMHO

RE: ezFAQ 0.0.2.1 (to be compatible with redmine 0.8.2) - Added by Chaoqun Zou over 8 years ago

Alexander Kirillov wrote:

Hi Chaoqun,

This version indeed works with redmine 0.8.2.
Thanks a lot.

I've attached lang/ru.yml you may freely use
when distributing your plugin.

I'd also suggest to change all occurrences of FAQ
in the UI into a localized string.

Hi, Alexander
Thanks for your support and suggestion.
I will upload a updated version 0.3.1 with localized FAQ label soon. Please check the plugin's wiki.

RE: ezFAQ 0.0.2.1 (to be compatible with redmine 0.8.2) - Added by Alexander Kirillov over 8 years ago

Hi Chaoqun,

I've attached a patch to ezfaq_plugin-0.0.2.1 which provides full russian l10n.
Sorry I didn't have time for nice coding but still it might help you to find and fix some hardcoded and missing messages.

Thanks for your efforts,
Sasha

ezfaq_plugin-0.0.2.1.patch.20090410 - russian l10n (7.47 KB)

RE: ezFAQ 0.0.2.1 (to be compatible with redmine 0.8.2) - Added by Chaoqun Zou over 8 years ago

Alexander Kirillov wrote:

Hi Chaoqun,

I've attached a patch to ezfaq_plugin-0.0.2.1 which provides full russian l10n.
Sorry I didn't have time for nice coding but still it might help you to find and fix some hardcoded and missing messages.

Thanks for your efforts,
Sasha

Hi, Alexander. Thanks for your contribution.
I have make the faq labels localizable in version 0.3.2(see wiki PluginEzfaq).
And I have completed ru.yml by your patch today. It should be in version 0.3.3.
When you update redmine to 0.8.3, you can use that version and have a full localized plugin.

RE: ezFAQ 0.0.2.1 (to be compatible with redmine 0.8.2) - Added by james pic over 8 years ago

Hi, thanks a lot for sharing!
I just changed the show template to let the answer be right after the question, and this french translation.
Cheers!

fr.yml Magnifier - french (1.3 KB)

RE: ezFAQ 0.0.2.1 (to be compatible with redmine 0.8.2) - Added by Chaoqun Zou over 8 years ago

james pic wrote:

Hi, thanks a lot for sharing!
I just changed the show template to let the answer be right after the question, and this french translation.
Cheers!

Thanks, james.
And if you use edge redmine from svn, you can try an updated version of ezFAQ at wiki PluginEzfaq

RE: ezFAQ 0.0.2.1 (to be compatible with redmine 0.8.2) - Added by Akiko Takano over 8 years ago

Hello!
Today I've just installd this plugin for Redmine0.8.3.
And I translated language file into Japanese for our use.

If you don't mind, please join this file to your language files.
(Sorry I have not tried latest ezFAQ(0.2x), so that I think this file is only for 0.0.2.1.)

ja.yml Magnifier - translated Japanese. (1.43 KB)

RE: ezFAQ 0.0.2.1 (to be compatible with redmine 0.8.2) - Added by Chaoqun Zou over 8 years ago

Akiko Takano wrote:

Hello!
Today I've just installd this plugin for Redmine0.8.3.
And I translated language file into Japanese for our use.

If you don't mind, please join this file to your language files.
(Sorry I have not tried latest ezFAQ(0.2x), so that I think this file is only for 0.0.2.1.)

Thanks for your support.

RE: ezFAQ 0.0.2.1 (to be compatible with redmine 0.8.2) - Added by Davide Saurino over 8 years ago

I installed 0.0.2.1 version of this plugin and translated it to italian.
You can find the translation in attachment, feel free to use it.

it.yml Magnifier - italian translation (1.28 KB)

RE: ezFAQ 0.0.2.1 (to be compatible with redmine 0.8.2) - Added by Danila Nikolaev almost 8 years ago

which version compatible with redmine 0.9.3?

Errors with Redmine 1.0.5 stable - Added by Pedro Gutierrez almost 7 years ago

I'm using Redmine 1.0.5.stable (MySQL) with ezFAQ plugin 0.3.5 and am suffering a number of problems I've been able to workaround.
But there is one that seems more difficult: When I attach a new file (a jpg screen capture) to a faq and try to display it with double exclamation marks It doesn't work. I receive the following error

internal_error.jpg (71.1 KB)

(1-14/14)