Feature #10043

Limiter un role ou un utilisateur a un certain nombre de tracker

Added by Brice Beaumesnil almost 6 years ago. Updated almost 6 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Permissions and roles
Target version:-
Resolution:Invalid

Description

Exemple : nous définissons un nouveau rôle pour un corps de métier bien précis : le service d'assistance utilisateur (SAU).
Ce service fait le lien entre les utilisateurs et le projet, son rôle est donc de remonter des demandes d'assistance vers le service de développement.

L'idée est de restreindre ce rôle SAU à la création de Demandes d'Assistance seulement : donc ils ne doivent saisir que des demandes concernant ce tracker (donc interdire la définition de demandes concernant les autres trackers). Ce sera aux développeurs de définir si ces demandes d'assistance sont des demandes d'évolution ou de bug.


Related issues

Duplicates Redmine - Feature #7839: Limit trackers for new issue to certain roles Closed 2011-03-11

History

#1 Updated by Etienne Massip almost 6 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

Please write in English, see SubmittingBugs.

#2 Updated by Florian ROBERT almost 6 years ago

There is a way to answer to your need without developement; you can create two projects, one with access for SAU and developers and one sub project with access for the developers only. On the first project you activate only the tracker "Demande d'assistance" and on the second you activate "evo, ano..;". The developers check the first project and if the issue is appropriate they copy it to the second changing the type of tracker, and they link the both issues.

Also available in: Atom PDF