Feature #7839

Limit trackers for new issue to certain roles

Added by Ryan Cross over 6 years ago. Updated over 1 year ago.

Status:ClosedStart date:2011-03-11
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Issues permissions
Target version:3.3.0
Resolution:Fixed

Description

I'm looking for a way to limit the Tracker Type of new issues for certain users, for instance;

A Project Manager can create a New Feature, but not a New Bug.
A Tester can create a New Bug, but not a New Feature.

In Roles and Permissions, I can give someone "Add Issue" privileges, but I can't limit the type of issues they can add.

I've also tried modifying the Workflow so that a Project Manager has no workflow for a new bug, but this doesn't restrict them from creating one.

There seems to be lots of related questions or issues for this topic

See:
http://www.redmine.org/boards/2/topics/20599
http://www.redmine.org/boards/1/topics/4809?r=22297#message-22297
http://www.redmine.org/boards/1/topics/15294?r=15305#message-15305
#3726
#973
#2467
#285
#1462
#2791
#2240
#2905
#2240
#1966
http://www.redmine.org/boards/1/topics/19832


Related issues

Related to Redmine - Feature #285: Tracker role-based permissioning Closed
Related to Redmine - Feature #3726: Trackers per Role Closed 2009-08-10
Related to Redmine - Feature #973: Assign different status sets and workflows for separate p... New 2008-04-02
Related to Redmine - Feature #2467: To control the permissions of users against 'Tracker', 'C... New 2009-01-08
Related to Redmine - Feature #1462: Access control to trackers by user roles/profiles New 2008-06-16
Related to Redmine - Feature #2905: Enable per-tracker issue status set Closed 2009-03-05
Duplicated by Redmine - Feature #10043: Limiter un role ou un utilisateur a un certain nombre de ... Closed
Duplicated by Redmine - Defect #12718: User with role without any worflow right for tracker can ... Closed

Associated revisions

Revision 15430
Added by Jean-Philippe Lang over 1 year ago

Adds Issue#allowed_target_trackers (#7839).

Revision 15464
Added by Jean-Philippe Lang over 1 year ago

Limit trackers for new issue to certain roles (#7839).

Revision 15472
Added by Toshi MARUYAMA over 1 year ago

generate i18 keys (#7839)

Revision 15478
Added by Jean-Philippe Lang over 1 year ago

Merged 15430, 15464 to 15469, 15475, 15476 (#285, #7839).

Revision 15480
Added by Toshi MARUYAMA over 1 year ago

Merged r15472 from trunk to 3.3-stable (#7839)

generate i18n keys.

History

#1 Updated by Ryan Cross over 6 years ago

I should add that this seems like it would make a lot of sense to include in the 1.2 version when refactoring the issues permissions.

#3 Updated by Etienne Massip over 6 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closed as duplicate of #2791.

#4 Updated by Ryan Cross over 6 years ago

  • Status changed from Closed to Reopened

I listed that issue as a duplicate in my comment, but none of these issues seem to be getting any attention. The issue you listed is over 2 years old and has no follow up.

Can someone please address what the status of this issue is? Is is possible to assign this (or one of the other duplicates) to a version/milestone?

#5 Updated by Etienne Massip over 6 years ago

  • Status changed from Reopened to Closed

You can propose a patch in #2791 if you need this to be treated faster.

#6 Updated by Ryan Cross over 6 years ago

  • Status changed from Closed to Reopened
  • Assignee set to Jean-Philippe Lang

Etienne, this isn't about a patch. Its about making sure the issue is looked at properly. None of the issues I found, or the one you proposed is on anyone's radar.

If this is a "Won't fix", that's fine but no body is even looking at the issue. There are lots of references to this general problem, but no single issue where anyone can collaborate or realize its even an issue.

Please consider connecting these dots into a unified issue if that is what you want to do, but just closing this issue again is eliminating it from attention.

#7 Updated by Ryan Cross over 6 years ago

I should clarify - its not about a patch YET. If we can discuss the issue and get some consensus on how to address the issue, then we can look at getting a patch made.

#8 Updated by Etienne Massip over 6 years ago

  • Status changed from Reopened to Closed

Closed as duplicate of #285.

#9 Updated by Etienne Massip over 6 years ago

I'm trying to do the same thing as you, that is to have only one or two issue only to be able to focus on.

Theses original issues are usually the ones duplicated and so, the ones to be kept opened.

#10 Updated by Etienne Massip over 6 years ago

  • Assignee deleted (Jean-Philippe Lang)

#11 Updated by Jean-Philippe Lang almost 5 years ago

  • Subject changed from Limit or Restrict new issue types to certain users to Limit trackers for new issue to certain roles
  • Status changed from Closed to New
  • Resolution deleted (Duplicate)

I'm reopening it as it's a subset and more specific than #285.

#12 Updated by Terence Mill almost 5 years ago

+1

#13 Updated by ilqar Caferov about 4 years ago

+1

#14 Updated by Sam He about 4 years ago

+1

#15 Updated by Sam He about 4 years ago

Actually, can we define a special status like 'null' to represent a issue to be created ? Thus we can leverage the existing workflow function to control which role is able to create the tracker.

#16 Updated by Toshi MARUYAMA almost 4 years ago

#17 Updated by Toshi MARUYAMA almost 4 years ago

  • Related to Feature #973: Assign different status sets and workflows for separate projects added

#18 Updated by Toshi MARUYAMA almost 4 years ago

  • Related to Feature #2467: To control the permissions of users against 'Tracker', 'Category' and so on. added

#19 Updated by Toshi MARUYAMA almost 4 years ago

  • Related to Feature #1462: Access control to trackers by user roles/profiles added

#20 Updated by Toshi MARUYAMA almost 4 years ago

  • Related to Feature #2905: Enable per-tracker issue status set added

#21 Updated by Marius Garbea almost 3 years ago

@Toshi MARUYAMA
I understand that this feature is implemented.
In which version?
In which build?
Actually, there's a list of features that are reported here as implemented. Each of them suggested an implementation. How are each of them implemented?

#22 Updated by Toshi MARUYAMA almost 3 years ago

Not implemented yet.

#23 Updated by Malan Van Eck over 2 years ago

Hi there Guys!

I had a problem with the permissions and then I got to this post,
I started reading it and got very very Happy.
Until I got to the end and saw that there is no release for this.

PLEEEEEEEEEEAAAAAAASSSSSS Make this change! It will help a lot of people!

:-)

#24 Updated by Franck Valetas over 2 years ago

+1

#25 Updated by Zer Guz over 2 years ago

+1
We have added a tracker "Task" and want only the managers to be able to add/edit it.

#26 Updated by Alex Petty over 2 years ago

+1

This is very much needed! (Does anyone have happen to have a 3.0.x compatible patch for this?)
Hopefully Jean-Phillipe Lang (and his core team) will recognize the importance of this feature and add it to Redmine's next version.

The end-to-end for how I envision this working is:
(1) Administrator creates a role (let's call it role A)
(2) Administrator assigns a user (or group) role A.
(3) Through the implementation of this feature, the administrator will be able to define which tracker-types that role A is capable of creating (so long as role A has been assigned the "add issue" permission)
(4) When the user possessing role A (and also having the "add issue" permission) clicks the "New Issue" tab, the user will see only those trackers which were defined as "can create this tracker" to role A.
(5) If the user has multiple roles with "can create this tracker" defined, each having their own set of permissible trackers, the user will be able to create the super-set of all trackers from all assigned roles.

This would truly be a GREAT and VALUABLE feature for Redmine's overall flexibility in configuration, and would be hugely appreciate by many!!

+1000

-Alex Petty

#27 Updated by Anton Titkov about 2 years ago

Hello everyone!
Please check a plugin http://www.redmine.org/plugins/tracker_hider and share your thoughts. Thanks!

#28 Updated by Anton Titkov about 2 years ago

Anton Titkov wrote:

Hello everyone!
Please check a plugin http://www.redmine.org/plugins/tracker_hider and share your thoughts. Thanks!

Hello guys!
Has enybody tested the plugin?
It allows to hide issues under selected tracker for roles/users within a project. It solves the subject partly as i see.

It would be nice to get some feeback from you!
Thanks!

#29 Updated by Sebastian Paluch almost 2 years ago

+1

#30 Updated by Radek Chan over 1 year ago

I tested the plugin. User is still able to create a new issue, but it cannot view it after that.

Anton Titkov wrote:

Anton Titkov wrote:

Hello everyone!
Please check a plugin http://www.redmine.org/plugins/tracker_hider and share your thoughts. Thanks!

Hello guys!
Has enybody tested the plugin?
It allows to hide issues under selected tracker for roles/users within a project. It solves the subject partly as i see.

It would be nice to get some feeback from you!
Thanks!

#31 Updated by Steven Wong over 1 year ago

yes, just as Radek said.

I think it should according by users or roles to control whether to create or edit or view the issues with trackers?

Radek Chan wrote:

I tested the plugin. User is still able to create a new issue, but it cannot view it after that.

Anton Titkov wrote:

Anton Titkov wrote:

Hello everyone!
Please check a plugin http://www.redmine.org/plugins/tracker_hider and share your thoughts. Thanks!

Hello guys!
Has enybody tested the plugin?
It allows to hide issues under selected tracker for roles/users within a project. It solves the subject partly as i see.

It would be nice to get some feeback from you!
Thanks!

#32 Updated by Jean-Philippe Lang over 1 year ago

  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang
  • Target version set to 3.3.0
  • Resolution set to Fixed

Implemented as part of #285 in 3.3.0.

Also available in: Atom PDF