Defect #10348

Wrong issue statuses assignment during issue copy

Added by Vitaly Klimov over 5 years ago. Updated 5 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Fixed Affected version:1.3.1

Description

Defect: during issue copy available statuses computed based on source issue status. Also when creating issue status validation performed upon source issue status as well.

Steps to reproduce:

  1. Create two statuses - one should be default, other should be any other status, let's say their names are New and Done
  2. Create workflow that allows current user to change status from New to Done only and does not allow to change status from Done to any other
  3. Create new issue
  4. Change status to Done
  5. Copy issue - on the issue creation screen you will be able to choose New status
  6. After issue creation status in the new issue will be reverted to Done

This defect also allows users to copy issues and assign them statuses they should not be able to assign.

Attached is the patch that solves this inconsistency

issues_controller.patch Magnifier (1.25 KB) Vitaly Klimov, 2012-03-01 15:46


Related issues

Related to Redmine - Feature #23610: Reset status when copying issues Closed
Duplicated by Redmine - Defect #16230: Copying issue to other tracker without the status Closed

History

#1 Updated by Go MAEDA over 2 years ago

  • Duplicated by Defect #16230: Copying issue to other tracker without the status added

#2 Updated by Go MAEDA over 2 years ago

  • Related to Feature #17576: Ability to choose, in administration page, the behaviour of status during copying issues added

#3 Updated by Florian ROBERT about 2 years ago

+1 no needs of #17576 if this is corrected

#4 Updated by Toshi MARUYAMA about 1 year ago

  • Related to deleted (Feature #17576: Ability to choose, in administration page, the behaviour of status during copying issues)

#5 Updated by Toshi MARUYAMA about 1 year ago

#6 Updated by Toshi MARUYAMA 6 months ago

  • Status changed from New to Needs feedback

Can we close this issue by fixed #23610?

#7 Updated by Go MAEDA 5 months ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Fixed

Toshi MARUYAMA wrote:

Can we close this issue by fixed #23610?

You are right. Fixed by #23610.
This problem never happen in upcoming Redmine 3.4.0 because issue status is reset to default when an issue is copied.

Also available in: Atom PDF