Defect #10483

After creating a new relation on a issue the relation is not displayed, in some cases

Added by Dieter Egert about 6 years ago. Updated about 6 years ago.

Status:NewStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:UI
Target version:-
Resolution:Cant reproduce Affected version:1.3.1

Description

I have a isse created. Then I open the issue details and a a relation to an other issue:

  • Related issues: add,
  • select 'follows' in pulldown menue
  • key in issue no
  • key in 1 into field 'Delay'
  • Select 'Add' button

Expected: Relation is shown to other issue no
Displayed: No relation is shown. (This error does not always appear..!)
But: After refreshing of browser the relation is shown

Used:
Firefox 10.0.2 (also found on earlier versions)
Redmine 1.3.0.stable (also on Redmine 1.3.1.stable 8857)
Ruby version 1.8.7
Ruby Gems 1.6.2
Rack 1.1.1

History

#1 Updated by Ivan Cenov about 6 years ago

I confirm in Redmine 1.3.2 and in trunk r9244.

Note that I have installed redmine_better_gantt_chart plugin 0.6.3.

#2 Updated by Dieter Egert about 6 years ago

Note: I also have some plugins installed:
  • redmine_better_gantt_chart V 0.5.0
  • redmine_issue_due_date 0.1.0
  • redmine_better_gantt_chart 0.5.0
    and others..

#3 Updated by Jean-Philippe Lang about 6 years ago

  • Resolution set to Cant reproduce

Please try without plugins.

#4 Updated by Ivan Cenov about 6 years ago

Redmine trunk r9258 without plugins.

It seems that the problem reproduces when the issue has not any relations added and the first relation that is added is of follows type.

If a relation of other type is added first, then it and the next relations of any type are added and displayed immediately.

#5 Updated by Dieter Egert about 6 years ago

Yes, I can confirm the conditions described by Ivan Cenov
for occurence of disappearing new relations.

#6 Updated by sheerinjerr aifseng about 6 years ago

  • Assignee set to Jean-Philippe Lang

-

#7 Updated by burgsgill aifseng about 6 years ago

-

#8 Updated by Etienne Massip about 6 years ago

  • Assignee deleted (Jean-Philippe Lang)

#9 Updated by raankelv John about 6 years ago

  • Assignee set to Toshi MARUYAMA

-

#10 Updated by Toshi MARUYAMA about 6 years ago

  • Assignee deleted (Toshi MARUYAMA)

Also available in: Atom PDF