Defect #11304

Issue-class: status-1, status-2 etc. refer to status position instead of status id

Added by Peter Schuler over 5 years ago. Updated about 1 year ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:UI
Target version:2.1.0
Resolution:Fixed Affected version:

Description

There are additional classes in the html code for issues, like the one for status. But the number is generated by position instead of id. I'd think intended behavior would be to generate those by id.

Steps for reproduction:
Add a theme/css with status color coding, e.g.:

/* use MantisBT style coloring by status */
table.issues tr.status-1 { background: #fcc; } /* new */
table.issues tr.status-2 { background: #cdf; } /* assigned / in progress */
table.issues tr.status-3 { background: #dfd; } /* resolved */
table.issues tr.status-4 { background: #fdf; } /* feedback */
table.issues tr.status-5 { background: #eee; } /* closed */
table.issues tr.status-6 { background: #fd6; } /* rejected */

Add a new ticket status and move it's position to No.1 - all colors would be mixed up.

Additional thoughts:
If this is intended (didn't find any documentation) it might be needed for some JavaScript sorting, however even in that case it would be better to have a more distinguished name or supply both (like status-1 and statusid-3 or something similar).

Associated revisions

Revision 10078
Added by Jean-Philippe Lang over 5 years ago

Changed issues css class from status-{position} to status-{id} (#11304).

History

#1 Updated by Mischa The Evil over 5 years ago

  • Resolution set to Duplicate

Looks like it's the same as #2071?

#2 Updated by Peter Schuler over 5 years ago

Sorry, that ticket didn't came up in my searches.

The concept behind the issue is the same, however this one refers to status instead of priority. IMHO this is a little bit more serious with status, because status refers to an nominal scale and priority refers to an ordinal scale.

But I agree that a simple workaround is to use priority=ID so that it has low severity.

#3 Updated by Jean-Philippe Lang over 5 years ago

  • Target version set to 2.1.0

Agreed.

#4 Updated by Jean-Philippe Lang over 5 years ago

  • Category set to UI
  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang
  • Resolution changed from Duplicate to Fixed

Change done in r10078.

#5 Updated by Michel Albert about 1 year ago

Jean-Philippe Lang wrote:

Change done in r10078.

I've just run into the same issue. Had a look at r10078 and wonder if priority does not have the same issue?

#6 Updated by Mischa The Evil about 1 year ago

Michel Albert wrote:

[...] Had a look at r10078 and wonder if priority does not have the same issue?

It had and it was fixed in a similar way in r10079 for #2071 (note that the commit message contains a typo; read: priority-{id} instead of status-{id}).

Also available in: Atom PDF